Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I am fairly inexperienced with Linux. I currently use SUSE9.1 on a file server which has been fantastically providing a mirrored storage for my network on /home/public. I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    1

    Automount Firewire Problems


    Hi,

    I am fairly inexperienced with Linux.

    I currently use SUSE9.1 on a file server which has been fantastically providing a mirrored storage for my network on /home/public.
    I have the most current kernel updates.

    I recently added a Lacie Big Extreme Firewire drive (1Tb) to back-up my entire system.

    I have mounted it at /public2.

    My network (Windows XP, MacOSX) sees the drive and writes to it fine, for a bit. Whilst doing file transfers it becomes inaccessable. Sometimes after several hours. Other times after several minutes.

    Windows says stuff like the file name is too deep, to data can't be written as the drive can't be found. Mac says there is an error reading from the destination drive....etc etc.

    I try to remount with limited success. Usually the only thing to bring the drive back is a system reboot. When the drive comes back on line the mount point has been changed to:

    /media/ieee1394_sbp2-00d04b460806583e-0-0p1

    This is, I believe, is caused by the automount function added by subfs. However, I have no intention to hot plug this device as it is permanently attached. (BTW-Even at that mount point the drive goes off-line and after reboot a new mount point is created. It never seems to to stay connected for long).

    How do I disable the automount function?
    Where do I find the conf files for subfs?

    Does anybody know how to help?

    Thanks.

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    You should be able to change the automount option in /etc/fstab. I think you just remove the "auto" option. As for hotplugging, you can change it so that the script doesn't do anything when that device is attached, i.e. add a simple if statement. The scripts are in /etc/hotplug (not 100% sure of location).

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •