Find the answer to your Linux question:
Results 1 to 2 of 2
I'm scratching my head here. I have a VIA VT6410 based generic PCI IDE controller that I want to use in my backup array of old hard disks. I've tried ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie Mad Professor's Avatar
    Join Date
    May 2006
    Posts
    142

    VT6410 PCI IDE Controller, no drives.


    I'm scratching my head here.

    I have a VIA VT6410 based generic PCI IDE controller that I want to use in my backup array of old hard disks.

    I've tried several different distros,
    ubuntu, opensuse, and centos.

    I run dmesg it shows two ide controllers active.
    One based on via82xxxx chipset and the other on VT6410.

    I take the card out and run dmesg again it shows one active ide controller which is the via82xxxx controller.

    When I plug the card in and hook up a drive, the actual hard-disk does not show up in fdisk.

    When I check to see what module is being loaded for vt6410 I get pata_via.

    I've replace cables, tried other hard-drives, screw with the master/slave jumpers and tried the card in another machine and get the same result. But If I install and run a windows O/S and install the driver for the ide card, it can see the hard-disk fine in computer management.

    What could be wrong?

    All the distro kernels have support for it, so what could be preventing the psychical drive from showing up in linux?

    I'm running opensuse 11.2 in minimal server selection.

    Any ideas?

  2. #2
    Just Joined!
    Join Date
    Apr 2010
    Posts
    1
    I'm having this same problem and have not been able to find any resolution elsewhere. Were you ever able to get this to work, and if so is there a link to a solution somewhere?

    I am running Kubuntu 9.10. Any help would be appreciated.

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •