Find the answer to your Linux question:
Results 1 to 8 of 8
Hi, I'm using the current release of Damn Small Linux on a thin client of about 2005 vintage with what seems to be fairly standard hardware, running a Via Eden ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    4

    No mouse in X on DSL


    Hi, I'm using the current release of Damn Small Linux on a thin client of about 2005 vintage with what seems to be fairly standard hardware, running a Via Eden processor. It's booting from a CF card. I have a standard PS/2 keyboard and PS/2 mouse attached. The boot process seems to go fine, and even detects the mouse on /dev/psaux. However, once it boots into X, the mouse will move a tiny bit, then it refuses to move again. The keyboard does work however.

    I've tried plugging in a USB mouse, and tried every setting by running "dsl xsetup" and no change. I know the mouse works because the software on the original CF card with the thin client's original useless software uses the mouse fine.

    BTW, I am trying to post on DSL's forums but having trouble doing so. Maybe someone here can provide some input in the mean time.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Post the contents of /etc/X11/xorg.conf file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    4
    I wasn't able to find the file you refer to, but I did change to a different mouse. I was using a generic optical mouse, and changed to a generic ball mouse. Both have the same buttons and wheel....and the ball mouse works! WTF? I know the optical mouse isn't broken. Any idea what gives?

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    It looks like DSL is using Generic Configuration for your mouse and its not working with Optical Mouse.
    Lets check xorg.conf file exists in X11 folder.
    Post the output of this
    Code:
    cd /etc/X11
    ls
    In case there isn't any, we will try to create new and configure mouse correctly.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Jan 2010
    Posts
    4
    Here's the contents of /etc/X11:

    drwxr-xr-x 6 root root 60 Jan 18 09:25 .
    drwxr-xr-x 54 root root 320 Jan 18 09:25 ..
    lrwxrwxrwx 1 root root 18 Jan 18 04:21 X -> /KNOPPIX/etc/X11/X
    drwxr-xr-x 2 root root 1024 Feb 25 2003 Xresources
    drwxr-xr-x 2 root root 1024 Oct 28 2004 app-defaults
    drwxr-xr-x 4 root root 1024 Feb 23 2003 fonts
    drwxrwxr-x 2 root root 1024 Nov 5 2007 pwm
    lrwxrwxrwx 1 root root 24 Jan 18 04:21 rgb.txt -> /KNOPPIX/etc/X11/rgb.txt
    lrwxrwxrwx 1 root root 26 Jan 18 04:21 rxvt.menu -> /KNOPPIX/etc/X11/rxvt.menu
    lrwxrwxrwx 1 root root 23 Jan 18 04:21 xsetup -> /KNOPPIX/etc/X11/xsetup

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    In which distro did you execute that command? Are you using Knoppix LiveCD or DSL installed in your Hard disk?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Jan 2010
    Posts
    4
    I have DSL 4.4.10 on a compact flash card. I used Unetbootin to place the dsl-4.4.10.iso on the CF card.

  8. #8
    Just Joined!
    Join Date
    Jan 2010
    Posts
    1

    USB optical Mouse Not Working

    Hi, Ihace dsl 4.4.9 and i can`t get my optical USB mouse working. dsl detects my mouse but it doesn't work. I don`t have the xorg.conf file.
    A little help please!
    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •