Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, Distro: Archlinux DE: Xfce4 I've recently installed Arch on my main PC, and I decided to use Xfce4 desktop environment as appose to gnome that I use on my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38

    [SOLVED] HAL not auto-mounting NTFS partitions


    Hi,

    Distro: Archlinux
    DE: Xfce4

    I've recently installed Arch on my main PC, and I decided to use Xfce4 desktop environment as appose to gnome that I use on my laptop. Firstly, I had to search round for an icon theme to get any of the icons working (they were all just papers with red crosses in them to start with), which I think is taking lightweight a bit too far :P, but just my opinion.
    Now i've got that sorted I turned to the problem of auto-mounting partitions. I'm having some trouble getting HAL to auto-mount my NTFS partitions which have my documents and music on. They are NTFS because i've got dual boot windows, and had windows before Archlinux so NTFS was the logical fs type to use. I think HAL is auto mounting dvd's etc. (can't be sure as I aren't in Arch at the minute)

    I can mount the NTFS partitions manually using:

    mount -t ntfs /dev/sda(number from 1 through 3) /mnt/sda(1 through 3)
    However, I can only access this via root, so I carried out:

    chmod scott.scott /mnt/sda(1-3)
    or something similar and that works fine, so I know they can be mounted successfully. I've tried auto-mounting them using fstab but can't seem to get this working, and I would rather not have fstab auto-mount them, I would rather let HAL sort all that out for me.

    I have also added the line

    exec ck-launch-session startxfc4
    to ~/.xinitrc and still no luck in getting them to auto-mount.

    I have checked that dbus, hal, consolekit and xf86-input-evdev are all installed (although im not sure what xf86-input-evdev does).


    Has anyone got any ideas why its not auto-mounting the NTFS partitions. My laptop mounts the NTFS windows partition fine using gnome.

    Thanks,
    Scott.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    If you haven't already installed it, Linux uses the ntfs-3g package for working with NTFS partitions:

    NTFS Write Support - ArchWiki
    oz

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38
    Hi Ozar,

    ntfs-3g is only to allow writing to ntfs, it shouldn't have anything to do with auto-mounting... auto-mounting is taken care of by HAL and Dbus... I will try ntfs-3g anyway but I can't see it making a difference. Thanks anyway.

    Any other ideas,
    Scott.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Nov 2009
    Location
    France
    Posts
    292
    I would rather not have fstab auto-mount them, I would rather let HAL sort all that out for me
    HAL has no reason to mount fixed blocks where there are no plug/unplug events. Partitions not listed in fstab have no reason to be mounted at boot, as far as I understood.

    HAL can't help you here, even if you launch halevt, as there are no events.

    Are they mounted at boot if they are in fstab ?

    If they are in fstab, does
    Code:
    mount -a
    successfully mount the partitions ?

  6. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    If you want to always mount a permanent partition, fstab is the best option.

    I think, though I haven't tried, that you can get these automounted using thunar-volman in XFCE. They should at the least show up as an icon in thunar and mount when you click on it.

    Rather than an ugly chmod hack to deal with permissions issues, you can install and use pmount and use that to mount as your user.

    What was the trouble you were having with fstab? We can probably help you through it. You do need ntfs-3g to mount from fstab.

    NTFS Write Support - ArchWiki
    Fstab - ArchWiki

  7. #6
    Just Joined!
    Join Date
    Jan 2010
    Posts
    38

    [SOLVED] HAL not auto-mounting NTFS partitions

    Right,

    Sorry for the delayed reply, I've just been that hacked off with Arch all day that I couldn't be bothered to do anything with it. It's kept me up into the early hours of the morning for a number of nights lol. There should be a general rule that by no means should anyone begin messing with linux after 9:30pm or you'll be up till 3/4/5am. Its 3:25am now lol.

    Anyway, i've managed to get the partitions to auto-mount using fstab, easier than I thought, I just followed the fstab wiki on the Archlinux wiki. Problem is, even though I have added 'user' to all of the partition lines in fstab, I can only access them via root. Not sure why this is.

    Reed9 I read the man page for pmount and I don't understand a single bit of it lol. And would that work with hdd partitions with it being intended for plug and play devices?.

    *EDIT* Sorted it, I forgot to install ntfs-3g after i'd configured fstab. So I installed ntfs-3g through pacman, didn't have to do anything else apart from reboot, because udev takes care of things I think. So now its allowing me to access all the partitions, and it auto-mounts them to /mnt/sda1...2...3 and so on.

    Had a bit of a problem with the volume mixer not allowing me to access it saying something along the lines of "it may be a permissions issue" but after I installed Rhythmbox it all worked fine :S not sure what that was about.

    Feel like im getting somewhere now, just need to install a couple of things and sort a few minor problems out I think thats about it. Archlinux running on laptop and main pc.

    *EDIT*

    Thanks so much for your help, really nice people on this forum,
    Scott.
    Last edited by ScottWilson1990; 01-27-2010 at 03:15 AM. Reason: SOLVED PROBLEM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •