Find the answer to your Linux question:
Results 1 to 4 of 4
I've searched and posted, and tried a buncha stuff, and still no joy. I am running Mandriva 2010 on a Toshiba Laptop with an HP P1006 Laserjet. Also an Asus ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3

    [SOLVED] Printer Not Working in Any Distro


    I've searched and posted, and tried a buncha stuff, and still no joy.

    I am running Mandriva 2010 on a Toshiba Laptop with an HP P1006 Laserjet. Also an Asus eee with Joliecloud.

    Both of these were working until two weeks ago. Suddenly I can't print from either of these computers. My wife's MacBook and my son's Windows 7 computer both work with this printer. Neither of my Linux boxes is working.

    This is sudden. It was working, and now not

    The queues are enabled, I've reloaded the CUPs dirvers.

    Can anyone suggest a solution?

    SteveB

  2. #2
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3

    Printing Problem

    I have been using Mandriva for about 6 weeks. I changed over from Ubuntu because all of my hardware worked with it out of the box. I was having problems with Pulse Audio on Ubuntu.

    A week ago, my HPLaserjet P1006 printer stopped working.

    The software recognizes the printer is on line; the printer management says that it has sent the job to the printer, and that it has printed. Only it hasn't.

    Now I'm getting "job pending," messages instead of the complete message that I was getting before. In the printer setup screen, it is "enabled."

    I hooked up two other computers to the printer, a MacBook and a laptop running Windows 7. Both print imediately. Only my Mandriva doesn't work.

    Does anyone know how to solve this problem?

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    1
    Hi Steve!

    I'm a huge Mandriva fan, so let's see if we can get you working. I had this same problem only this morning.

    1) Do you have hplip installed? Just enter "hplip" in the Mandriva Control Centre "Install & Remove Software" section (in the Search bar at the top right). The Search results should come back with "hplip-gui". What's your version? If it's 3.9.12 you have the latest version. Congrats. If not, choose the software and Apply.

    2) Install the printer via MCC (Mandriva Control Centre). If you've already done this, skip to Step 3. If you haven't, choose "Hardware" in the left-hand blue list of options when you first enter MCC. There'll be an option "Configure printing & scanning". Choose the sub-option with the big icon "Set up the printer(s)...". Pick "New...Printer" in the top left and go through the dialog boxes to install. If you try to print a Test Page at this point, it will not work. Because....

    3) That's not all. The P1006 requires a plug-in according to HP Tech Support. See https: //answers.launchpad.net /hplip /+question /49302 (get rid of the space: I can only post URLs after I've made >= 15 posts) for details. So, if you have the latest hplip utilities, do the following:

    3a) open a Terminal/Konsole window.
    3b) su to log in as super user
    3c) type "hp-plugin". Presss <Enter>. A dialog box will pop. Just move through that. The plugin driver will be downloaded from an HP server, if you choose the first option to download it from an HP server.
    3d) If the hp-plugin process proceeds okay, you'll now having a working printer! This is what it looked like for me:

    [root@localhost ksaugustin]# hp-plugin

    HP Linux Imaging and Printing System (ver. 3.9.12)
    Plugin Download and Install Utility ver. 2.1

    Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.

    error: PolicyKit support requires DBUS or PolicyKit support files missing
    /Checking for network connection...
    Downloading configuration file from: (redacted due to post limitations)
    Checking for network connection...
    Downloading plug-in from: (redacted due to post limitations)
    Receiving digital keys: /usr/bin/gpg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0xA59047B9
    Verifying archive integrity... All good.
    Uncompressing HPLIP 3.9.12 Plugin Self Extracting Archive.................................

    HP Linux Imaging and Printing System (ver. 3.9.12)
    Plugin Installer ver. 3.0

    Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.

    Plug-in version: 3.9.12
    Installed HPLIP version: 3.9.12
    Number of files to install: 28


    Done.

    Downloading firmware to device hp:/usb/HP_LaserJet_P1006?serial=AC2JQ0F...
    Firmware download successful.

    Plug-in installation successful.
    Error: "/root/.kde4/tmp-localhost" points to "/tmp/kde-root" instead of "/root/tmp/kde-root".
    (5842) KIconCache::loadCustomIndexHeader: Empty themes list

    Done.

    Hope this helps. Let me know how it goes. There's a lot you can do with the MCC. Make sure you have a play. It's a very powerful tool.

    Kaz Augustin
    Last edited by oz; 02-18-2010 at 02:21 AM. Reason: spam removal

  4. #4
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3

    Was Printer Not Working; now it is

    Thank you very much for the great help. It worked! I actually had to do it a couple of times; it worked o.k., I turned off the computer, and unplugged the printer, and then it didn't work. Ran the same procedure again and it seems to have stuck.

    Thanks again.]

    SteveB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •