Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
Clues: Clue 1- If you look really close to the booting process, you might notice as I did the following "Mounting USB filesystem" (among a bunch of USB initilizations). This ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2

    Clues:
    Clue 1-
    If you look really close to the booting process, you might notice as I did the following "Mounting USB filesystem" (among a bunch of USB initilizations). This cued me into the fact that the USB filesystem (or Memory Stick) was registering with my OS.

    Clue 2-
    At a command prompt, if you type "mount" you should see the USB device mounted. In my case I saw the following line:
    'usbdevfs on /proc/bus/usb type usbdevfs (rw)'

    Clue 3-
    I then went to "cd /proc/bus/usb" and looked at what was listed. In the list I saw "devices" so I looked in the file. Within this file I found that Linux was obviously registering my Memory Stick since it was showing me the Mfg info(SanDisk Corporation), Product info(Cruzer Mini) and even the Serial number for the stick!

    Conclusion: Linux was looking at my hardware but I was not accessing it properly

    Solution:
    Step 1-
    You need to umount the USB filesystem that the boot strap mounted. In my case I typed "umount usbdevfs" (OR umount /proc/bus/usb). The command took!
    NOTE: make sure that none of the active users are in the directory /proc/bus/usb or the usbdevfs will not unmount.

    Step 2-
    Assuming that you have edited your /etc/fstab file (mine has the line:
    '/dev/sda1 /mnt/usb auto noauto,user 0 0'); you can now mount the memory stick as YOU would like. I typed "mount /mnt/usb" (OR mount /dev/sda1)---BAM it worked.

    NOTE: When I type "umount /mnt/usb" the LED on my memory stick does not turn off.!?

    To the Linux experts:
    1-What is the difference between 'mtab' and 'fstab'?
    2-How can I change the boot process to mount the memory stick as I would like?
    3-Any reason the LED on my memory stick will not turn off? Is it ok to just pull it (after a umount)?
    4-If an initialization fails on boot, is there a way to get more information on the failure (my eth0 is failing and the best information that I can see from Linux is "Check cable".)

  2. #12
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You shouldn't umount the usbdevfs. It's not there to access USB memsticks, it's there to provide information on the current state of the USB bus. It really has nothing to do with the memstick at all, it's just a part of the initialization of the USB subsystem.

    1. mtab lists the currently mounted filesystems, while fstab lists all "potential" filesystems. For example, if you have "/dev/sda1 /mnt/usb auto noauto,user 0 0" in your fstab, that tells the mount command that there can be a mountable filesystem on /dev/sda1. When you actually mount it, it will be added to mtab. When you umount it again, it will be removed from mtab.
    2. Wouldn't that be a bit strange? What if you don't have the memory stick plugged in when you boot?
    3. Unmounting a filesystem doesn't do anything to shut down the underlying device. It just synchronizes and disassociates the actual filesystem on the device. Since the filesystem is synchronized, though, it's OK to just unplug it after you umount it.
    4. How to get info on that really depends a bit, but for almost all init scripts, you can just check your logs (in /var/log) for any information on what might have gone wrong. If you want explicit help with your NIC, I suggest you start a new thread for it.

  3. #13
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2
    Dolda2000's response begs for the question of why unmounting it will allow me access to the Memory Stick. While umounting 'usbdevfs', I have tested the Stick and it will give and take files on both my LinuxBox and my Micorsoft Box. If I leave 'usbdevfs' mounted and try to mount the memory stick, not only do I lock up Linux Terminals that attempt the mount, but the shutdown gets frozen. How can I leave the 'usbdevfs' in place and still mount the memory stick?

    2. My interest in understanding how to change the boot process is more from a fiddle-with-the-system standpoint than a best-practices standpoint. At some point I am going to add more HD space to the system, and I will want to make sure it mount during the boot sequence.

    Thanks for the insight on the other points.

  4. #14
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That seems like a bug to me. Actually, now that I think about it, the filesystem that should be mounted on /proc/bus/usb is called "usbfs", not "usbdevfs". I think "usbdevfs" is the (very) old filesystem that was superceeded by "usbfs". What distro and kernel are you using, NoviceWilly?

    2. In that case, try replacing noauto,user in fstab with just "auto". That will mount it during boot, but that will result in root mounting it, which means that if you have to fiddle with umasks a bit to make sure that normal users have the proper permissions to it.

  5. #15
    Linux User sheds's Avatar
    Join Date
    Nov 2004
    Location
    ??????????
    Posts
    342
    I got to the point where i can view and copy files from the stick, but i can't modify, add or erase from the usb stick. Why is this? Here's my fstab file that contains the line to add the usb stick during booting, if it helps you to answer.

    Code:
    /dev/hdc8 / ext3 defaults 1 1
    none /dev/pts devpts mode=0620 0 0
    none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
    none /mnt/cdrom2 supermount dev=/dev/hdb,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
    none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0
    /dev/hdc1 /mnt/win_c ntfs iocharset=iso8859-1,ro,umask=0 0 0
    /dev/sda1 /mnt/win_c2 vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
    /dev/hdc5 /mnt/win_d ntfs iocharset=iso8859-1,ro,umask=0 0 0
    /dev/hdc6 /mnt/win_e ntfs iocharset=iso8859-1,ro,umask=0 0 0
    none /proc proc defaults 0 0
    /dev/hdc7 swap swap defaults 0 0
    This line here is the one maybe you are missing so your stick is recognized at booting time.

    Code:
    /dev/sda1 /mnt/win_c2 vfat iocharset=iso8859-1,codepage=850,umask=0 0 0

  6. #16
    Just Joined!
    Join Date
    Oct 2004
    Posts
    7
    hey guys
    my stick still does NOT WORK!!!
    a few moments after the mount -t auto ..... command,
    the system hangs! but, as i said earlier, the LED on my stick lights up.
    any wisdom?

  7. #17
    Just Joined!
    Join Date
    Nov 2004
    Posts
    45
    Just try the following:

    mount /dev/sda /mnt/winc2

    or:

    mount -t vfat /dev/sda /mnt/winc2

    The reason:
    If Linux happens to see the disk as one big partition (as it may seem in your case) then try to mount the whole of the special device, because just maybe then Linux will be able to use it right. Post back to tell if this works or not. The reason I recommend this is because I tried to mount one partition of the possible four, and Linux got confused.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •