Find the answer to your Linux question:
Results 1 to 5 of 5
I'm on a new netbook using Ubuntu 9.10 and I cannot figure out how to disable tap-to-click on my touchpad. I figured it would be simple enough to use SHMConfig, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    14

    Disabling Tap-to-Click


    I'm on a new netbook using Ubuntu 9.10 and I cannot figure out how to disable tap-to-click on my touchpad. I figured it would be simple enough to use SHMConfig, however; every post I've seen says they have something similar to this in xorg.conf
    Code:
    Section "InputDevice"
    
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/psaux"
    Option "Protocol" "auto-dev"
    Option "HorizScrollDelta" "0"
    EndSection
    Instead, I have this ...

    Code:
    Section "InputDevice"
            Identifier  "Mouse0"
            Driver      "mouse"
            Option      "Protocol" "auto"
            Option      "Device" "/dev/input/mice"
            Option      "ZAxisMapping" "4 5 6 7"
    End Section
    I have tried simply changing the driver entry to "synaptics," however when I run SHMconfig it says the driver hasn't been loaded.

    Any Ideas?

    Thank in advance,
    Ryan

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    You should be able to disable it in the graphical menus. There should be a tab in the Mouse control panel for "Touchpad" that will let you disable tapping.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Just Joined!
    Join Date
    Sep 2009
    Posts
    14
    Quote Originally Posted by techieMoe View Post
    You should be able to disable it in the graphical menus. There should be a tab in the Mouse control panel for "Touchpad" that will let you disable tapping.
    That was indeed one thing I looked for ... but the option is not available.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2009
    Posts
    14
    Anyone? .....

  6. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I believe this should still work for Ubuntu 9.10, but HAL is going away so it won't work in 10.04.

    As it stands, you need to edit/create a HAL policy.

    There should be a default file you can copy over
    Code:
    sudo cp /usr/share/hal/fdi/policy/10ovendor/11-x11-synaptics.fdi /etc/hal/fdi/policy/11-x11-synaptics.fdi
    Open for editing
    Code:
    gksudo /etc/hal/fdi/policy/11-x11-synaptics.fdi
    And then I believe if you change these three lines, replacing the '1' with '0'.
    Code:
    <merge key="input.x11_options.TapButton1" type="string">1</merge>
            <merge key="input.x11_options.TapButton2" type="string">2</merge>
            <merge key="input.x11_options.TapButton3" type="string">3</merge>
    Should look like
    Code:
     <merge key="input.x11_options.TapButton1" type="string">0</merge>
            <merge key="input.x11_options.TapButton2" type="string">0</merge>
            <merge key="input.x11_options.TapButton3" type="string">0</merge>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •