Find the answer to your Linux question:
Results 1 to 5 of 5
I have a DWL-650+ wireless cardbus from D-Link that was working in windows but does not work with Suse 9.1. I went to the D-Link web site and look for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Location
    Victoria, BC, Canada
    Posts
    13

    Wireless internet "DWL-650+ "


    I have a DWL-650+ wireless cardbus from D-Link that was working in windows but does not work with Suse 9.1.

    I went to the D-Link web site and look for driver for Linux and they don't have any.

    My router is the DI-614+ is part of the D-Link AirPlus™ series which is supported by linux. If my DWL-650+ wireless card for my laptop can't work in linux, I would like to know of one that can work with my DI-614+.

    Thanks!

  2. #2
    Linux Enthusiast scientica's Avatar
    Join Date
    Sep 2003
    Location
    South- or "Mid-" Sweden
    Posts
    742
    I'm not very keen on wifi but, there might be a driver here: (I tried to google a little and this showed up as one of the results, the file http://www.linux-wlan.org/docs/wlan_adapters.html.gz contains DWL-650 and the "linux support/AVS Tested" header for it says "Linux-wlan-ng" - I guess that means their linux-wlan-ng driver supoorts it )
    http://www.linux-wlan.com/linux-wlan/index.html
    Regards Scienitca (registered user #335819 - http://counter.li.org )
    --
    A master is nothing more than a student who knows something of which he can teach to other students.

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Location
    Victoria, BC, Canada
    Posts
    13
    I got my laptop to reconize my DWL-650+ as: D-Link ACX 100 22Mps wireless interface. I belive this is because the ACX 100 is the chip set in the card.

    I think my problem is with the configuration of the card. I am using the Yast network card configuration.

    In the Wireless setting, since I use wep encryption, I put the key with the Hexadecimal type and the Operating Mode to Managed.

    I tried changing the options but still no luck.

    I found a few RPMs for the ACX 100 but still no luck.

    RPMs are: acx100-utils-0.2.0-1.pre6.rh73.dag.i386.rpm
    acx100-utils-0.2.0-1.pre8.1.el3.dag.i586.rpm

    An other thing I found is: acx100_bin_20030716.tgz which gives me the "Driver" for the ACX 100 in a folder call: Acx100Drv. In that folder I have a file called: "installAcx100" but I can get it to install anything. (Maybe I have to wrong RPMs or driver???)

    I think I am very close to make it work. Still need help in figuring this wirreless card out.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2004
    Location
    Victoria, BC, Canada
    Posts
    13
    I know why I couldn't do the make install, the make rpm was not install.

    Not much was install in the personal version. Even then, I still can't make it to work. I tried to follow the instruction found on the Suse forum but still no luck.

    I got the Kernel and the Kernel-source, the make and the GCC. I have my XP driver for my card ready. And I also have the ndiswrapper ready to go.

    I get this error:
    /lib/modules/2.6.5-7.111-default/extra/ndiswrapper.ko
    bash: /lib/modules/2.6.5-7.111-default/extra/ndiswrapper.ko: Permission denied
    when I follow the instruction sound on the previous mentioned Suse Forum.

    I need some help real bad.

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    1

    acx100

    I am just going to start working on mine to get it working soon. Suse detects it as you say, but it does not talk to it. I read that you will need to install the firmware files manually as they are not allowed to ship these.

    from http://www.novell.com/documentation/...ld_readme.html
    Some wireless LAN cards (PrismGT, Centrino, Atmel, ACX100) need firmware to operate. Due to licensing issues, we cannot ship these firmware binaries. Please read /usr/share/doc/packages/wireless-tools/README.firmware for information on how to obtain and install the firmware.
    If you have it working please let me know how
    dwp@oddpost.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •