Find the answer to your Linux question:
Results 1 to 5 of 5
Using Debian Lenny. I have been having problems with the Internet the last couple weeks. I lose my connection to the Internet and then I'll get it back. I haven't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Dec 2008
    Posts
    166

    Connection to Internet goes in and out


    Using Debian Lenny.

    I have been having problems with the Internet the last couple weeks.
    I lose my connection to the Internet and then I'll get it back. I haven't
    changed any config files, so don't know why this is happening.

    I have XP installed on another partition and when I lose the connection
    with Debian I switch over to check and the connection there is good.

    I have included some info below:

    etc/network/interfaces
    The loopback network interfaceE]
    auto lo
    iface lo inet loopback

    # The primary network interface
    allow-hotplug eth1
    iface eth1 inet dhcp
    hostname Debian
    Code:
    ethtool eth1
    Settings for eth1:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: Unknown! (65535)
    Duplex: Unknown! (255)
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: umbg
    Wake-on: g
    Current message level: 0x00000007 (7)
    Link detected: no


    Code:
    lspci -nn
    02:0c.0 Ethernet controller [0200]: Intel Corporation 82540EM Gigabit Ethernet Controller [8086:100e] (rev 02)

    I'm not sure what else to include.
    Would appreciate any help.

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,043
    Howdy JoeS.

    What Network manager are you using? If Wicd. I find in my AntiX 8.5 Debian Squeeze WICD 1.7.0 That under Preferences>External Programs setting mine from Automatic to dhclient works better at not dropping connections.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Linux Newbie
    Join Date
    Dec 2008
    Posts
    166
    I'm using Network Manager. I think it is the problem. It wants to pick the wrong
    card: eth0 and I am using eth1. I can't find a way to change it.
    I disabled it and used:
    dhclient and this got a connection. I think I will have to find another program or
    live without it. I can have a connection and then later in the day I can try to
    use the Internet and the connection has been lost. Network Manager drops it
    for some reason.

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,043
    I think I will have to find another program
    I have more than just one (Wicd) installed. I also have Ceni installed also.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Linux Newbie
    Join Date
    Dec 2008
    Posts
    166
    Thanks. I'll check those out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •