Find the answer to your Linux question:
Results 1 to 4 of 4
Using Debian Lenny I'm looking for drivers for a some ethernet cards: 02:07.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec: 8139] (rev 10) Macronix, Inc. [MXIC] MX987x5 [10d9:0531] ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Dec 2008
    Posts
    166

    Need drivers for ethernet cards


    Using Debian Lenny

    I'm looking for drivers for a some ethernet cards:
    02:07.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec: 8139] (rev 10)
    Macronix, Inc. [MXIC] MX987x5 [10d9:0531] (rev 25)
    and
    Dlink dfe-538tx

    I found some drivers at:
    Realtek
    These are for the Realtek card.
    They are: UnixWare 7.1.x and SCO Unix 5.0.X
    Which one would I use for Debian Lenny?

    I couldn't find any for the Macronix

    I found this site for dlink:
    ftp://ftp.dlink.com/NIC/dfe538tx/Driver/Linux/
    File:Makefile 3 KB 21/10/04 12:00:00 AM
    File:Readme.txt 2 KB 21/10/04 12:00:00 AM
    File:rtl8139.c 54 KB 21/10/04 12:00:00 AM
    I'm not sure what to do with the dlink.

    I'm not familiar with Linux drivers.
    I don't know if this is the right way to go or if there are drivers for linux already.

    Appreciate any help.
    Thanks

  2. #2
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    I don't know about the other two, but your first card should probably work out-of-the-box. I have a card with the same chipset and it works in most distributions without a hitch. I know it works in Ubuntu, and for Gentoo I have to compile a kernel module for it (though I just compile the driver into the kernel). I realize this isn't very beginner-friendly, but I think you should be able to get it up and running in Debian without too much trouble.

    It's been a while since I've run Debian, but you can try the command 'modprobe 8139too' (as root). This loads the kernel module named 8139too, which is the one I use in Gentoo with my card - it works fine.
    Stumbling around the 'net:
    www.cloudyuseful.com

  3. #3
    Linux Newbie
    Join Date
    Dec 2008
    Posts
    166
    I tried
    Code:
    modprobe 8139too
    That didn't work for me. There must be something else
    I need to do.
    Here is my /etc/network/interfaces:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback
    address 127.0.0.1
    netmask 255.0.0.0

    # The primary network interface
    allow-hotplug eth1
    iface eth1 inet dhcp
    hostname Debian
    This is /etc/resolv.conf
    domain cg.shawcable.net
    search cg.shawcable.net
    nameserver 64.59.135.133
    nameserver 64.59.135.135
    nameserver 64.59.128.120
    I tried a Ubuntu live CD and I could get the Macronix card to work, but not the Realtek.

    Thanks

  4. #4
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    There are a few different things to try.

    After the 'modprobe' command, what exactly did you try? Normally you would check 'ifconfig' and see if the interface is coming up at all. Even if it does, you might not be able to access the internet if you don't have DHCP up and running (most home routers use DHCP by default).

    Anyhow, I always use Gentoo's documentation for these sorts of things. Here's the relevant page (scroll down to the manual setup), most of it applies to Debian as well (if you see the command 'emerge X' just substitute it for 'apt-get install X').
    Stumbling around the 'net:
    www.cloudyuseful.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •