Find the answer to your Linux question:
Results 1 to 7 of 7
First of all, i must say that i don`t know actually if it`s a hardware problem or one of the kernel`s... After i`ve compiled my kernel(2.4.22 and 2.6.6), the message ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Location
    Bucharest - RO
    Posts
    64

    FAT32 suport is still ALPHA


    First of all, i must say that i don`t know actually if it`s a hardware problem or one of the kernel`s...
    After i`ve compiled my kernel(2.4.22 and 2.6.6), the message at boot is like this:
    Code:
    Checking filesystems:
    Warning: FAT32 suport is still ALPHA
    There are differences between boot sector and it`s backup
    Differences:(offset:original/backup)
    ...
    at then the differences, some numbers i realy don`t understand what mean...
    What`s wrong and what should i do?please don`t tell me i have to format my hd...

  2. #2
    Just Joined!
    Join Date
    Feb 2004
    Location
    Bucharest - RO
    Posts
    64
    ok, i understand nobody knows what is happening with my hard-disk.
    As a solution to my problem, if anyone happens the same thing, i should say him to modify his /etc/fstab the lines with his partition problems by puting an 0 at the end of the line(not 1 or 2 or anyting else).That would skip the check of the partitions at boot.
    That`s all i could do for now...i will try to find a better solution, and that would not be formating my hd

  3. #3
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    i think the problem is that the linux fat tools have only alpha support for checking fat filsystems.. disableing the checks at boot is fine and there should be no other problems. providing you can read/write np

  4. #4
    Just Joined!
    Join Date
    Feb 2004
    Location
    Bucharest - RO
    Posts
    64
    I don`t know what to say... I`ve installed Slackware 9.1 too and it`s the same thing. Installed also lilo( i`ve had grub) and after that, fedora gave me erors, big ones because of those partitions, and didn`t let me login. It said something about "check for consistency or press CTRL+D to reboot".
    And now i took the same solution: no partition check at boot.
    Must be something wrong in here!

  5. #5
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    probably because you installed lilo over grub.
    I've never used lilo, but i've never heard one
    good thing about it, mainly because it's not self-configurable.
    i don't know about the 0s/1s/2s, but I've noticed that
    fstab installation defaults only ever put 1 or 2 if it's a partition
    that was created and labelled with linux.
    Emotions are the key to the soul.
    Registered Linux User #375050

  6. #6
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Don't bother having Linux check your FAT fs, let Windows do that. Setting the last number in the appropriate fstab line to 0 will stop that. Read the fstab man page about that.

    There's plenty of good things about lilo, but I don't care to explain. Installing lilo over grub will cause no harm. It's just like installing grub over the Windows MBR, it simply replaces it.

  7. #7
    Just Joined!
    Join Date
    Feb 2004
    Location
    Bucharest - RO
    Posts
    64
    probably because you installed lilo over grub.
    No, you are wrong. It happened also with grub...And in my opinion, lilo is the best!
    As for what valan said, i`ve already told that. But it isn`t a good solution! Long time ago, when i first installed linux on my box, it didn`t gave this error. So you check the fstab man page and tell me if you find something about this thing...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •