Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm running Ubuntu 10.04, and am having trouble getting it to recognize my flash drive in the USB port. It showed up once in the Computer - File Browser ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    100

    [SOLVED] USB flash drive not recognized


    Hi,

    I'm running Ubuntu 10.04, and am having trouble getting it to recognize my flash drive in the USB port. It showed up once in the Computer - File Browser and I was able to mount it and access the files on it, but since then it doesn't show up. It works fine on my Ubuntu 9.10 distro. I get the same results on both distos when I run #lsusb# The results are:

    Code:
    Bus 001 Device 002: ID 05dc:a701 Lexar Media, Inc. JumpDrive FireFly
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Can anyone tell me how to fix things so I can access the flash drive?

    Thank you very much. The Forum has been a great help to me.

    Jim

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Does fdisk -l command list USB Drive?
    Plug-in stick and execute this in Terminal :
    Code:
    tail -s 3 -f /var/log/messages
    sudo fdisk -l
    Post output here
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    100

    USB flash drive and DVD drive recognized intermittently

    Hi,

    Thanks for the reply and the helpful info. This morning the flash drive worked for a while, then a little later, after installing some Movie Player apps, the system quit recognizing it, and now also doesn't recognized the DVD drive. I think when it's not recognizing one, it also won't recognized the other. The last time I booted the system, it wouldn't recognized the USB wifi device. I rebooted again, and then the wifi device wast there. Here's the output from the code you gave me with the flash drive plugged in:

    Code:
    Aug 18 11:46:51 jim-laptop kernel: [  817.828871] Initializing USB Mass Storage driver...
    Aug 18 11:46:51 jim-laptop kernel: [  817.829275] scsi2 : SCSI emulation for USB Mass Storage devices
    Aug 18 11:46:51 jim-laptop kernel: [  817.829959] usbcore: registered new interface driver usb-storage
    Aug 18 11:46:51 jim-laptop kernel: [  817.829974] USB Mass Storage support registered.
    Aug 18 11:46:56 jim-laptop kernel: [  822.848907] scsi 2:0:0:0: Direct-Access     LEXAR    JD FIREFLY       1100 PQ: 0 ANSI: 0 CCS
    Aug 18 11:46:56 jim-laptop kernel: [  822.859302] sd 2:0:0:0: Attached scsi generic sg2 type 0
    Aug 18 11:46:56 jim-laptop kernel: [  822.878517] sd 2:0:0:0: [sdb] 1003520 512-byte logical blocks: (513 MB/490 MiB)
    Aug 18 11:46:56 jim-laptop kernel: [  822.882354] sd 2:0:0:0: [sdb] Write Protect is off
    Aug 18 11:46:56 jim-laptop kernel: [  822.899101]  sdb: sdb1
    Aug 18 11:46:56 jim-laptop kernel: [  822.946345] sd 2:0:0:0: [sdb] Attached SCSI removable disk
    Thanks again

    Jim

  4. #4
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    100

    Problem solved

    I think the problem is solved, at least for now. I installed the first OS update, and so far the system now recognizes the flash drive.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •