Find the answer to your Linux question:
Results 1 to 7 of 7
I have successfully gotten my USB hard drive mounted (/mnt/maxtor), but it is not accesible to the user I have tried chmod, which does not work (tells me it's not ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    40

    USB Hard Drive, CDROM, MP3


    I have successfully gotten my USB hard drive mounted (/mnt/maxtor), but it is not accesible to the user
    I have tried chmod, which does not work (tells me it's not allowed)
    I can access it as root

    I also have a usb CDROM (HP dc3000) which is recognized in /proc (cat /proc/scsi/scsi)
    It came up in the livecd (gentoo) install as /dev/sr1, but it is not there anymore, does anyone know how to find out where it has gone?

    Also, is there a good MP3 (acutally, OGG Vorbis) player (5gb, at least) that works as a mass storage device with linux (I have heard about the iRiver ihp-120, but it is out of stock everywhere)

    I also tried searching (This forum, and google) but it was no help

    -palmer

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Posts
    40
    Fixed:

    CD-ROM drive mounts as /dev/sr0, not /dev/sr1 like the livecd

    -palmer

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    40
    Fixed:

    Maxtor HDD

    must be umounted to be accessible by user
    Anybody have any clue as to why this happens?

    -palmer

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    As for the USB HDD, it depends. If root mounts it, it may be that the default umask is to disallow access from any others, depending on what filesystem is on it. If that's the case, if a user mounts it, it will apply the mounting user's UID to all files on it, which will make it accessible to that user.

    If you want to have it permanently mounted, you can just fix the umask settings so that it allows you the kind of access you want. See the manpage for mount and fstab for more info.

    If chmod isn't allowed, it's probably because the HDD is formatted with a filesystem that has no support for permissions, such as FAT. You could try formatting it with ext3 instead, if that's alright with the kind of thing you use it for.

  5. #5
    Just Joined!
    Join Date
    Oct 2004
    Posts
    8
    i know i'm just a n00b but i feel i oughtta give back to the forum community. but to add to what dolda suggested, y not just log in the terminal again as root and just add the options to change ownership to user and enter a umask value of something like "077" which'd give full access to the owner and no access to others in the group and no access to everyone else? so you'd just add the syntax "-o uid=USERNAME,umask=077 and try that for starters ^_^. i think that should work unless the HDD is a FAT,FAT16 or 32.

  6. #6
    Just Joined!
    Join Date
    Dec 2004
    Location
    N/A
    Posts
    2
    I got one automount usb flash memory question. This is kind of a very antique question, but please take a look.

    there are two ways for automounting usb flash memory, neither one works for me.

    (1) /etc/fstab
    changed to
    /dev/sdb1 /mnt/usbflash vfat noauto,user,umask=000 0 0
    and run
    init q

    (2) autofs
    auto.master
    /mnt/usbflash/ /etc/auto.usb --timeout=10
    auto.usb
    usbflash -fstype=vfat :/dev/sdb1

    then insert usb flash memory, nothing happened.

    Got any ideas?



    Quote Originally Posted by nvoke
    i know i'm just a n00b but i feel i oughtta give back to the forum community. but to add to what dolda suggested, y not just log in the terminal again as root and just add the options to change ownership to user and enter a umask value of something like "077" which'd give full access to the owner and no access to others in the group and no access to everyone else? so you'd just add the syntax "-o uid=USERNAME,umask=077 and try that for starters ^_^. i think that should work unless the HDD is a FAT,FAT16 or 32.

  7. #7
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Can you mount your USB device manually as /dev/sdb1? My USB device mounts under /dev/sda1. Maybe try that?
    Linux Mint + IceWM Registered: #371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •