Find the answer to your Linux question:
Results 1 to 3 of 3
Hi. Good day! I'm using F13. I have alsamixer and pulseaudio and Skype 2.1 Beta installed. Everything is fine except my microphone. I tried to plug it on every possible ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    27

    [SOLVED] F13. Mic not working. Skype 2.1 Beta. Pulseaudio. Alsamixer.


    Hi. Good day!

    I'm using F13. I have alsamixer and pulseaudio and Skype 2.1 Beta installed.
    Everything is fine except my microphone. I tried to plug it on every possible
    jack (front, line in, etc.) but it doesnt work. I can hear someone I called from
    skype, but he cannot hear me.

    I tried to change input devices on pavucontrol, and input source on alsamixer to
    microphone 1, microphone 2, and line in, still mic doesnt work. all volume on alsamixer is maxed up, including mic boost etc.

    I went to Skype Option > Sound devices, and when I look at microphone and speakers, its "Pulseaudio server (local)" and there's no other option. I'm using built in sound card HDA Intel.

    I did all possible way I could do. I'm trying to search on the net but cannot find a solution.
    I hope you can help me guys. Thanks a lot. Cheers.

    Additional info. my /etc/asound.conf
    Code:
    #
    # Place your global alsa-lib configuration here...
    #
    
    @hooks [
    	{
    		func load
    		files [
    			"/etc/alsa/pulse-default.conf"
    		]
    		errors false
    	}
    ]
    
    
     pcm.pulse {
        type pulse
    }
    
    ctl.pulse {
        type pulse
    }
    
    # for 5.1 speakers
    pcm.ch51dup {
             slave.pcm surround51
             slave.channels 6
             type route
             ttable.0.0 1
             ttable.1.1 1
             ttable.0.2 1
             ttable.1.3 1
             ttable.0.4 0.5
             ttable.1.4 0.5
             ttable.0.5 0.5
             ttable.1.5 0.5
    }
    
    
    
    options Intel index=0
    options Intel model=5stack 
    # add pulse
    pcm.pulse {
        type pulse
    }
    
    ctl.pulse {
        type pulse
    }
    pcm.!default {
        type pulse
    }
    ctl.!default {
        type pulse
    }

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    have you tried playing around with pulse audio applet and see if you have correct microphone enabled?

    you need to make sure microphone is plugged into microphone port, there should only be one, check your motherboard/laptop manual if they aren't labeled

  3. #3
    Just Joined!
    Join Date
    Sep 2009
    Posts
    27
    My microphone works now! All I have to do is unmute "Mic" and "S/PDIF" and mute "Smart 5.1" on alsamixer. I think I have a 5.1 Surround sound default setting coz I like to watch movies. I just need to turn off that and make the front jack to be mic.

    Mark the thread as solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •