Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I have been trying to use the above printer as a network printer by connecting it to the HP Jetdirect 175x gizmo. However, nothing I do works. I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2009
    Posts
    225

    Canon MP210 + Jetdirect 175x


    Hello,

    I have been trying to use the above printer as a network printer by connecting it to the HP Jetdirect 175x gizmo.

    However, nothing I do works. I have been round and round the configuration roundabout both on the JD and the CUPS Server without joy.

    I recently had the chance to put an HP printer on the JD and there was no problem configuring CUPS to use the networked printer. The issue seems to be that the JD and the Canon are not talking.

    Whereas I could print the JD's config page to the HP (there's a wee button on the JD that does this), I could not get it to print when the Canon was connected. The JD has 4 or 5 options as to which language it will use to "talk" to the Canon for this purpose but none of them works.

    The JD knows that the Canon is connected because, via its web interface, it shows me the make and model etc. The config page via the web interface shows that it is communicating with the Canon in "Bi-directional" mode whereas it was using "IEEE 1284.4" for the HP.

    Any attempt at printing results in the JD replying with "FF" and immediate shutdown of the connection.

    Is it a lost cause to try to get the Canon operational using the JD or does anyone have some voodoo?

    Cheers - VP

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,639
    Look on the HP web site for Jet Direct support. I had one that worked well with my HP all-in-one (print, scan, fax), but I never tried it with another manufacturer's printer.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •