Find the answer to your Linux question:
Results 1 to 7 of 7
Hello, I use CentOS with 2 PC HP Compaq 6005. The 2 one give the same problem. After a time of use (not constant), the pointer is blocked on the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2011
    Posts
    8

    mouse cursor blocks on the left in CentOS


    Hello,

    I use CentOS with 2 PC HP Compaq 6005. The 2 one give the same problem. After a time of use (not constant), the pointer is blocked on the left of screen. It is possible to move the mouse cursor horizontaly, but only if you move very very slowly. If you go a little faster, the cursor return on the left of the screen. For vertical move, no problem. I tried with different mice. CentOS is up to date. Does it exist a compatibility problem of HP PCs with CentOS ?

    wighou

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    USB or PS2 mouse? I have been running CentOS for years with both types of mice/track-balls and never saw this problem. So, if USB, how is your BIOS configured re. legacy USB keyboard/mouse support?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Feb 2011
    Posts
    8
    The mouse is ps2. But I have tried with usb too. Same problem. It occures just with these PC HP Compacq 6005. I did the same installation in an other type of PC. I have no problem. It mays exist a problem of compatibility between centos and the HP Compacq 6005.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    I wouldn't be surprised if it is a "lost interrupt" problem. Try booting your Linux kernel with APIC turned off.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  6. #5
    Just Joined!
    Join Date
    Feb 2011
    Posts
    8
    OK, to make this, I have to edit /boot/grub/menu.lst

    and add noapic at the end of the line beginning by kernel.

    True ? If the mouse works good after this, does a colateral effect exist ?

  7. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    Quote Originally Posted by wighou View Post
    OK, to make this, I have to edit /boot/grub/menu.lst

    and add noapic at the end of the line beginning by kernel.

    True ? If the mouse works good after this, does a colateral effect exist ?
    There are ALWAYS collateral effects! What they may be remain to be seen. Basically, your are disabling the Advanced Programmable Interrupt Controller (APIC) during the boot process. I think Linux is smart enough to work around that as this is a common solution for older, less "current"ly compatible hardware.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  8. #7
    Just Joined!
    Join Date
    Feb 2011
    Posts
    8
    I tried to add noacpi but the system can not boot.
    It remains blocked after the line :
    Memory for crash kernel (0x0 to 0x0) notwithin permissible range
    But this line is not the problem because without the noacpi option, it exists too, but the system boot normaly.
    The strange thing is that it booted normaly the first time I added the noacpi option and had no problem of mouse. I thought that the problem of mouse was solved but now, the system can not boot.

    OK, I solved the mouse problem booting with xen option. But now, the problem is that the X-server does not have "backing store" enabled. I can lead to graphical problem with the simulation software I use. Any idea to activate this backing store ?

    Last edit :
    And the ultimate problem is resolved adding
    Option "backingstore"
    to the Device section of the file /etc/X11/xorg.conf
    I hope that using the xen version will not cause more problem ...

    Thanks for your help Rubberman
    Last edited by wighou; 03-03-2011 at 06:54 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •