Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I have a drive with a very simple Linux kernel installed onto it, and I'm having trouble getting USB to work on a Lenovo x201i with a QM57 chipset. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2008
    Posts
    127

    USB not working properly on Lenovo x201i


    Hi,

    I have a drive with a very simple Linux kernel installed onto it, and I'm having trouble getting USB to work on a Lenovo x201i with a QM57 chipset.

    Previously I had kernel 2.6.30.5 and it worked. However, I don't have the .config file anymore, and I've since tried to rebuild a fresh 2.6.30.5 as well as the later 2.6.37 kernel, with full USB/HID support in the kernel configuration, yet USB doesn't work on these new kernels on the Lenovo laptop.

    On the older 2.6.30.5 kernel, lsusb immediately shows 2 Linux Foundation root hub, 2 intel rate matching hubs, and whatever inserted USB devices. However, for the 2 newer kernels, lsusb hangs for a very long time before showing just the 2 Linux foundation root hubs (and not the intel rate matching hubs nor any inserted USB devices). USB devices that are inserted are not detected nor do they work.

    All 3 kernels work on other desktop systems that I've tried.

    I'm guessing I'm missing some kernel configuration settings since my old 2.6.30.5 kernel seems to work. I just can't figure out what I'm missing. I've already enabled EHCI/OHCI/UHCI. What else could I be missing, and why specifically does the laptop not work?

    Thanks!
    Last edited by galapogos; 02-24-2011 at 03:31 AM.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,393
    Please post your kernel build .config file here (as an attachment, not inline, please).
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •