Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, I tried installing Red Hat linux on my Sata hard disk . As soon as the hardware detection phase starts it generates the error "No hardware detected". Please ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2011
    Posts
    3

    No hard drive found


    Hi all,

    I tried installing Red Hat linux on my Sata hard disk . As soon as the hardware detection phase starts it generates the error "No hardware detected". Please tell how to solve problem? (I have also tested RHLE 5, CentOS 5.4, but none of them detect the hard disk and I can not install anyone).
    I have installed Windows 7 on one of my disks and I have not any problem with it.
    I also changed storage configuration in Bios as AHCI, IDE, But it was not helpful.

    My Hardware config is as below:
    Mainboard: ASUS P6X58D premium,
    CPU: core i7 950,
    HDD: two 1 TB WD SATA3
    Ram: 6 GB (3*2 GB cruciall[/U][/U][/B]

    Regards

  2. #2
    Linux Newbie Nagarjuna's Avatar
    Join Date
    Feb 2011
    Posts
    122
    I remember someone having this same issue. I believe what they did to resolve it was change a BIOS setting. I know you said you did a little tinkering in your BIOS already, but look for anything that says 'SATA Enhanced' and try toggling it to "Combined".

    I can't promise your BIOS will be worded the same way, but try looking for something along those lines.

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hello

    I have that exact hardware except a little more RAM and can tell you that it works perfectly with all the distros (at least a dozen) that I've tried on it, but I have not tried running Red Hat, or any of its forks. In addition, I'm able to install Linux using the IDE or ACHI configurations in the system BIOS. I'd recommend rechecking your BIOS configs again.

    Otherwise, are you sure you burned the installation disks correctly, or could your SATA controller be acting up?
    oz

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2011
    Posts
    3
    Thanks for your comments,
    P6X58D has 2 SATA 6 ports and my hards were connected to those ports; When I connected my hards to SATA 3, linux recognized the hard derives.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •