Find the answer to your Linux question:
Results 1 to 4 of 4
Hi guys - Any help that you can provide would be very very much apprecaited. I have a Thinkpad T23 and my mouse on the keyboard is successfully working. It ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Location
    Dublin, Ireland
    Posts
    29

    USB Mouse - Thinkpad


    Hi guys - Any help that you can provide would be very very much apprecaited.

    I have a Thinkpad T23 and my mouse on the keyboard is successfully working. It is being recognized as a PS/2 and is mounted as /dev/mouse.

    But I have a USB mouse which i would like to be able to hot plug/unplug and use when needed. When I plug in the mouse I can see below that power is getting to it. But when I move the mouse nothing happens?

    How I can configure that BOTH my on-board mouse and USB mouse work at the same time? I believe that I have to edit the xorg.conf file? But I am not sure what exactly I have to enter.

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    You are right that xorg.conf must be edited. In the first section 'Section "ServerLayout"' you may already have the following line to allow more than one active mouse:
    Code:
        InputDevice    "DevInputMice" "AlwaysCore"
    And then you need a new section to describe your USB mouse. I don't have this set up, but the following is copied from my config file and should be of some guidance:
    Code:
    Section "InputDevice"
                                                                                    
    # If the normal CorePointer mouse is not a USB mouse then
    # this input device can be used in AlwaysCore mode to let you
    # also use USB mice at the same time.
            Identifier  "DevInputMice"
            Driver      "mouse"
            Option      "Protocol" "IMPS/2"
            Option      "Device" "/dev/input/mice"
            Option      "ZAxisMapping" "4 5"
            Option      "Emulate3Buttons" "no"
    EndSection
    I'd suggest you save under a different name your present,working config file, plug in your USB mouse and then run the configuration program for XF86. For us still using the older version, that would be
    Code:
    #  XFree86 -configure
    This must be done at a virtual terminal, outside of the GUI and it must be done as root. If the auto-configuration doesn't set-up both mice, but at least sets your USB mouse, you will have the information your need to finish the job manually.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Location
    Dublin, Ireland
    Posts
    29
    Thanks for your response. That worked, but just one more problem.
    I have to restart x server in order to get my mouse to work.

    Is there something else that I am missing to make it hot plug?

    Thanks again - I really appreciate your assistance

    NeilB

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Sorry, but I don't understand. Are you saying you can make it work, but only for that session? If this is the case, please walk me through what you do and what you see, step by step.

    Otherwise, maybe you are saying that it works when you start X with the USB mouse connected, but when you connect the mouse after starting X, the mouse is not recognised?

    If that is the case, it sounds like an issue with hot-plugging. I'm not sure what the fix is for that, but I think it is straightforward. I'd suggest a new post with something like 'usb hot plug problem' in subject line. Be sure and mention your distribution.
    /IMHO
    //got nothin'
    ///this use to look better

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •