Find the answer to your Linux question:
Results 1 to 4 of 4
Hardware: Asus N53S WD Passport 0730 (500gb hybrid drive w/ usb3.0) Procedure: 1) GRUB boots, drive detected 2) Kernel loads 3) Kernel detects sda1 and sda3 (skipping sda2) GRUB tab ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    20

    External USB 3.0 harddrive as root misdetects available partitions


    Hardware:
    Asus N53S
    WD Passport 0730 (500gb hybrid drive w/ usb3.0)

    Procedure:
    1) GRUB boots, drive detected
    2) Kernel loads
    3) Kernel detects sda1 and sda3 (skipping sda2)

    GRUB tab completion:
    (hd0,0) ext2
    (hd0,1) unknown

    fdisk output:
    primary partition 1 bootable, ext2
    primary partition 2 0x8e (linux lvm)

    from kernel init:
    ls /dev/|grep sda
    sda1
    sda3

    I've tested this with multiple kernel versions which work with an internally (sata 3gb/s) connected laptop hdd. Reverting to a usb 2.0 port does not solve the problem.

    Anyone have any clues as to what's going on here?

    I've also tried this in VirtualBox which demonstrates the same behavior when you create a device linked straight to the external harddrive.

    *edit*

    The init:
    #!/bin/busybox
    mount -t proc none /proc
    mount -t sysfs none /sys
    mount /dev/sda2 /mnt/root
    umount /proc
    umount /sys
    exec switch_root /mnt/root /sbin/init

    I've tried modifying the above to reference sda3 instead, but then it says "cannot open for read-only access"
    Last edited by KBAegis; 04-24-2011 at 06:20 PM. Reason: Addendum

  2. #2
    Just Joined!
    Join Date
    Apr 2006
    Posts
    20
    I should also note that the filesystems on partition 1 is ext2. That's pretty standard for a boot partition. When reformatting the whole of sda2 to fat, ext2, or reiserfs directly without lvm, all of which have kernel built-in fs support, this remains an issue leading me to suspect the usb3 driver.

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    Setting up /etc/fstab to use device ID's is not a good idea, because the id can change when you add/remove drives. IE, mounting /dev/sda1 is not a good idea. What I do is to boot into a live/rescue CD/DVD, create a label on each partition, mount the root partition, edit the /etc/fstab to use LABEL=partition-name instead of /dev/sda1, /dev/sda2, etc. Then, adding/removing storage units will not munge your file system mounts. You can also use UUID's instead of labels if you prefer, but myself I like to use labels as that makes it easier to move/replace storage units.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2006
    Posts
    20
    I can appreciate that. Ultimately, that depends on how rigid you want the definition to be. That having been said, the fstab preferences are only relevant once switchroot has been run, which is the problem at present. This precludes either of our preferences.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •