Find the answer to your Linux question:
Results 1 to 3 of 3
Alright so I have this computer that is about 6 years old and I've decided to wipe it clean and put a version of linux on it. I looked around ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    1

    Question Hard drive not detected in windows and linux but detected in bios


    Alright so I have this computer that is about 6 years old and I've decided to wipe it clean and put a version of linux on it. I looked around and decided on Mepis. After burning a dvd I realized, "Oh yea, my old computer doesn't have a dvd drive, its only a cd drive." So, and don't ask me why because it seemed like a good idea at the time, I put my hard drive into a newer computer with a dvd drive and installed it. Once I put the drive back into my old computer I slapped my forehead and realized it wasn't gonna work.

    Next I thought I'd install some other version of Linux on it that I can burn to a cd so I grabbed fedora 14. It loaded up fine and everything until I tried to run the installer. Apparently it sees two 3.2gb drives (one mounted and one unmounted) called fedora(I don't remember the exact names), a ~920 mb drive of free space, a 93kb drive of free space? and a 513mb drive (I don't remember the names). The hard drive should be 70gb so I'm assuming it isn't recognizing it. I also tryed installing VectorLinux as well with the same problem (although it was only finding the 93kb drive). Afterwards I figured reformatting it might help? so I put the hard drive back into my newer computer as a slave and started up vista off the master. Bios still sees it and allows me to boot off of it but if I boot up windows, it acts as if it isn't there.

    Any ideas?

    EDIT - Alright so windows sees it in device manager but not my computer. I'm still not sure what do from here though.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,592
    Usually, the system won't see the drive either because it wasn't formatted, or something has munged the partition table / boot loader. In Windows, you should be able to go to the storage manager tool and see/partition/format the drive.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    I'd redo the Fedora install, but this time, when you get to the partitition screen, jump to a virtual terminal (Ctrl+Alt+F2 usually), you should be at a prompt. Run the following commands and post the output:

    list the detected hard drives:
    Code:
    ls -d /sys/block/sd*
    show the partition table of one drive (the first one):
    Code:
    fdisk -l /dev/sda
    From there, we could help you determine the state of your drive(s) and even partition it manually, if need be. You could also blast the partition table from here, too, in an effort to try and "start fresh".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •