Find the answer to your Linux question:
Results 1 to 3 of 3
I've been having some trouble booting my computer lately, so I tried upgrading my BIOS. That didn't solve the problem, but now I have a new one. My network card ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    6

    Intel EtherExpress Pro 10/100 problem


    I've been having some trouble booting my computer lately, so I tried upgrading my BIOS. That didn't solve the problem, but now I have a new one. My network card is completely dead. It is detected by the eepro100 driver but neither generates nor receives any network packages.
    But here's the really weird thing. If, and only if, X is running, the card magically works again! And when I say running, I mean on screen, having it running and then switching to a text console will break the card again (even when it's up and running with connections etc.).
    It's like switching to X is like an on/off switch for the card.
    I've done some research on the problem and came up with this: I have an Nvidia Geforce 2 card, and I'm using their binary driver. Now, the network card will only work if the IRQ of the card is shared with that of Nvidia (IRQ 11, in my case). Any other IRQ renders the card useless.
    I never had this problem until I upgraded the BIOS (at least I think that's what did it), but I'm afraid I don't remember what IRQs were assigned to which cards before it went wrong.

    Here are my cards as reported by lspci:
    00:00.0 Host bridge: Silicon Integrated Systems [SiS] 745 Host (rev 01)
    00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS 530 Virtual PCI-to-PCI bridge (AGP)
    00:02.0 ISA bridge: Silicon Integrated Systems [SiS] 85C503/5513
    00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
    00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
    00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
    00:09.0 RF controller: Advanced Micro Devices [AMD] Am 1771 MBW [Alchemy] (rev 04)
    00:0a.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 05)
    00:0b.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
    00:0b.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
    00:0d.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
    00:0d.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
    01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev a1)


    Does anyone have a clue what might be causing this? I might try to downgrade to the previous BIOS version, but I'd like to avoid it if possible.

    Kristian Amlie

  2. #2
    Just Joined!
    Join Date
    Apr 2005
    Posts
    2
    I have the same sort of problem
    I installed mandrake 10.1 on my base compaq deskpro en PII333
    I have a usb mouse, the nic and mouse work fine on the installation program
    and when I use knoppix live cd.
    after the first installation the mouse would not work in X. It would work after I change the type. so I would chaging it to genric and it would work, after rebooting it stped working and I would change it to something else like ps/2 and it worked. then I would reboot again and it stoped working.
    I ran the update and updated all files security, bug fixes... and the nic stoped working. it would say interface eth0 failed on boot up. I didn't feel like messing with modules so I reinstalled the distro. and the card still didn't work. so, I thought it might be shot. I tried a different card and it did not work. lsmod showed that the eepro100 is still loaded and it loaded e100. i could rmmod e100 and eepro100, but eepro100 kept popping back up when I wuld do an lsmod. I put the old eepro100 card back in and it worked. I did the update and it stopped working again. I checked the cmos setup and the way compaq has it setup is that the video card, usb, and nic all share irq 11. I have never trused irq sharing. I left the nic on irq 11 and change the video to irq 9 and disabled the usb and pluged a the mouse in the ps/2 port with the adapter and the mouse and nic still have the same problem. I don't know where to start troubleshooting from here.
    I don't like the idea of trying a different type of nic, since the the bios seems to have settings for the one that comes with the machine. I feel like it would be giving up if I settled fora different nic. I see fixing problemsas a learning experience, if everything worked fine out of the box no one would know anything.

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    6
    I have solved the problem I had with the card, but it might disappoint you to learn that the fix was to replace my mainboard. Some days after I posted that message, it started behaving even worse, and after I opened up my PC, I discovered some components that had actually leaked some kind of fluid over the board. Clearly defective components.
    So it was all bad luck that it happened just when I upgraded my BIOS.

    Kristian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •