Find the answer to your Linux question:
Results 1 to 2 of 2
Hi! I have a 512MB Philips GoGear mp3 player, which has always worked find until today. Now even if I delete every file (including its SETTINGS.DAT), it says that only ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    27

    Question Mp3 player showing wrong free space


    Hi!

    I have a 512MB Philips GoGear mp3 player, which has always worked find until today. Now even if I delete every file (including its SETTINGS.DAT), it says that only 269.2 out of 462.2MB space is free. (Also on Windows XP, and the mp3 player's own function "memory available" states that only 269MB space is free.)

    Partitionmanager also simply shows that that 193MB is occupied. (Also, it states that the file system is "unknown", although it apparently knows FAT16...)


    inux-gq7v:~ # blkid
    [...]
    /dev/sdc1: SEC_TYPE="msdos" LABEL="Philips" TYPE="vfat"




    linux-gq7v:~ # fdisk /dev/sdc -l
    Note: sector size is 2048 (not 512)

    Disk /dev/sdc: 485 MB, 485752832 bytes
    218 heads, 34 sectors/track, 32 cylinders
    Units = cylinders of 7412 * 2048 = 15179776 bytes
    Sector size (logical/physical): 2048 bytes / 2048 bytes
    I/O size (minimum/optimal): 2048 bytes / 2048 bytes
    Disk identifier: 0x00000000

    Device Boot Start End Blocks Id System
    /dev/sdc1 * 1 32 474300 6 FAT16
    Partition 1 does not start on physical sector boundary.


    What's interesting is the last line here. What does it mean? Can that be the reason for the strange behavior? Any other ideas?

    I don't really dare format the drive, because I have done that once already with another mp3 player, which doesn't ever play any mp3's anymore. (Basically it has been reduced to a regular USB drive.)

    (I'm using SuSE 11.3, btw., although the problem doesn't really look distro-specific in my opinion.)


    Thanks,
    Agoston

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Posts
    27

    Thumbs up SOLVED: Mp3 player showing wrong free space

    The solution:

    dosfsck -rv /dev/sdc1

    (see Mp3 player showing wrong free space)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •