Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I am trying to copy my 80GB harddrive to a 320GB harddrive (i.e clone it to a larger HDD drive) Because I am running out of space on the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2011
    Posts
    96

    dd command and HDD drive problem ?


    Hi,
    I am trying to copy my 80GB harddrive to a 320GB harddrive (i.e clone it to a larger HDD drive)
    Because I am running out of space on the 80 GB drive so I just want to have this system on a bigger drive.

    I have used dd if=/dev/sda1 of=/dev/sda2 bs=512

    After that had finished copying to the other drive I went and check if the first 80GB of the new harddrive was exact copy of the old 80GB harddrive.

    Basically I just hashed compared the 2

    dd if=/dev/sda2 bs=512 count=15625000 | md5sum
    dd if=/dev/sda1 bs=512 count=15625000 | md5sum

    both hashes where the same so the probablity that they are identical is almost 100% (for the first 80GB of the 320GB HDD)

    But when I try to boot the 320GB drive it fails to do anything I just get at the BIOS screen
    saying something like press F1 to continue or F2 to run to bios setup.
    If you press F1 it either spites back out the same message or hangs with a cursor.
    If I press F2 it brings me as usual to the bios/cmos config page where I can turn on and off settings. (note: I have tried almost every combination of settings I can think of that would effect the booting process none of them worked )

    the 320GB HDD is Western Digital drive
    is sata 16MB cache WD3200AAKS
    LBA 625142448
    5VDC 0.65A
    12VDC 0.5A
    s/n: WCAV2V552233

    I am using an old dell dimension 4600 computer
    The 80GB pata harddrive came with the original dell computer

    The motherboard supports 2 sata devices and I have tried both the master and slave sata ports on the motherboard no luck.

    I know the sata ports are good because they worked with an other 500GB seagate sata drive I had lying around with an important linux distro that I cann't overlay for copying this 80GB HDD.

    I don't see much difference in the two sata harddrives hardware wise.
    But here is the spec's for the seagate 500GB that boots and works fine.
    seagate 500GB Barracuda 7200.12
    5v 0.72 A
    12V 0.52A
    Firmware: CC38
    Date Code:11154 Site Code WU
    S/N: 5VMJBVM6
    ST 3500418AS
    P/N: 9SL142-302

    I am curious to know why it is not working and what can be done to fix this.

    Also if your wondering why I am mixing sata with pata it is because I can buy sata for half the price of pata/ide hd drives.
    So I bought this sata 320GB hdd thinking I could do the same thing that I did with the 500GB sata drive that I had purchased a few months prior.

    If you need any more info like the bios version this dell dimension 4600 is running I would be more then happy to look up it up. Along with anything else needed.

    I hope it doesn't come down to a bios update since this bios already has the usb boot ability and other things that I wouldn't want to lose.
    BIOS updating is the last resort and I may even thing about getting another harddrive before this.

    Thanks for any help

  2. #2
    Just Joined! nigelc's Avatar
    Join Date
    Oct 2006
    Location
    Silverwater,NSW Australia
    Posts
    32
    Hello,
    What sort of bootloader is it and also which OS?

  3. #3
    Just Joined!
    Join Date
    Apr 2011
    Posts
    96
    Os is windows XP Professional 32bit
    Tomorrow I will try to copy a linux HDD to see if it's something funky with the OS
    But if it is the exact same copy byte for byte then it must be the firmware or hardware I am thinking
    Either the bios or the hdd's

    I will try also to install a new OS on to this drive first to see even if any OS can be booted from it as well.
    It is pretty new hard drive though.

    What sort of bootloader is it and also which OS?
    since dd is making an exact copy of the whole entire 80GB their should not be an issue with os or bootloader.
    Since the disk is exactly the same byte for byte.
    If the bios loads the mbr the rest should follow.

    Also the 80GB harddrive boots xp fine still so when I copied it to the 320GB hdd it should be an exact replica of it and boot fine as long as their is no firmware or hardware issues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •