Find the answer to your Linux question:
Results 1 to 3 of 3
Likely a linux kernel or driver question. We have a industrial type motherboard with 4 serial ports that will not work when running arch linux; and this problem has us ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2011
    Posts
    2

    Serial ports not functioning under Arch Linux or Ubuntu


    Likely a linux kernel or driver question. We have a industrial type motherboard with 4 serial ports that will not work when running arch linux; and this problem has us stumped. The ports work with windows embedded, so we know the hardware is good. The super IO chip on the MB is old enough that drivers should not be a problem. And the flow control pins work (indicate the correct voltage) when set manually through a comms tool (coolterm). However we cannot get the ports to communicate with known good serial devices (that work with other computers and with the same MB running windows embedded). Also worth noting is the same harddrive with this linux OS can be booted on a different industrial board and those serial ports work fine. Have tried booting ArchLinux and Ubuntu and both are encountering the same problem.
    The kernel is updated and auto compiled following update. setserial returns expected IRQ and address settings for the ports (matching up with bios settings), and running setserial with autoconfigure returns the same settings.
    Only odd thing noticed is that dmesg shows two different IRQs for ttyS0 in two different lines, but the other ports do not shows up this way. All ports indicate connected when tested with coolterm, but again no data is ever transmitted or received successfully!!
    Any ideas on the cause of this problem, or suggestions on how to better test are appreciated!!

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Have you tried the stty utility? I've had some success with it in the past, often simply setting it to the right baud was sufficient (especially when I found that some terminal emulators would change it themselves on start-up), e.g.:
    Code:
    stty -F /dev/ttyS0 115200
    Sometimes the 'sane' or 'raw' commands would help un-jigger it, too. As usual, do 'man stty' for more detailed info...

  3. #3
    Just Joined!
    Join Date
    Sep 2011
    Posts
    2
    Turns out all that was needed was to add pnpacpi=off to the kernel command line in /boot/grub/menu.lst. this turns off pnp management of the serial ports, which was disabling IRQ sharing that turns out to be required for the Super IO chip providing those ports.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •