Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Problem while cloning a hard drive

    I come here because I found no way, in 2 weeks' work now, to get around a problem that prevents me from cloning a hard drive.

    I have an old laptop (acer travelmate 280 from 2003) which has a 30 GB 4200rpm internal IDE HDD as its main an only drive. It actually contains 3 partitions, two of them containing an OS: XP home on the first, XP pro on the second. The third one is tiny and only contains utilities. As expected, there is a dual boot home/pro.

    The disk to which I want to move all these 3 partitions, is a samsung IDE HDD, 160GB, all stats identical (255 heads, 63 sectors/track, 512 byte sectors and blocks) except for the number of cylinders, of course the new one has a lot more of them. At first I planned to resize all partitions from the beginning, to have more space everywhere. When I saw it became troublesome I gave up on that and simply tried to clone the drive, keeping all partition sizes intact, having in mind to extend them afterwards, when I would see everything is working well.

    So I placed the new hard disk in an external USB case, and tried several ways of cloning the drive. First: Acronis True Image, which can clone the disk during windows startup. It works for around a minute, then stops. Same if using the Acronis live CD, which contains only the utility to do the cloning.

    Then I tried Drvcloner, a small utility for windows. Fast or slow mode, the same: it stops somewhere between 600MB and 1.1 GB, and either gives a "possible bad sector found while writing" message (in "fast" mode), or simply freezes (in slow mode, sector-by-sector copy). At that point I used another acronis utility to see the raw data on the new drive: it is strictly identical to the data of the old one, until a point beyond which there are only zeros everywhere, as should be expected. But no discrepancy in the last sectors, nothing

    Then I moved to a linux live CD, the latest Ubuntu Version available on the net, and tried sudo dd if=/dev/sda of=/dev/sdb. Again, the same stop, this time either at 300MB of copied data or somewhere around 700 MB. And the "conv=noerror" won't bypass this: it is a WRITE error!

    What is even more weird is that I tried HDD regenerator on this new disk: it did not find any bad sector in the first 7 GB! And I also tried the following: format the drive in NTFS, and copy a big 1.5GB movie to it: it worked, the file is not damaged, I did not watch it entierly to see wether there was a tiny fault indicating a bad sector, but still: the copy did not stop like that at 300 or 700 MB!

    So, what the h*$ is going on on that new drive? Is there a way, to bypass these write errors, just like dd can bypass read errors? I mean: see the problem, try to solve it, and if it fails, don't stop, continue with the next bolcks! 99% chance that this block falls somewhere not critical (I mean, a file that would prevent windows from running or something similar)!

    A friend of mine suggested me to use "cat", or even "more" commands, to do an even lower level copy of the disk. I still haven't tried those. But I would like to know, what do you people think of that? What is it that freezes any (usefull) copy on my hard drive? Is there a way to bypass it?

    Thank you very much for your help

    PS: the reason why I want so badly to clone my drive, is that this laptop comes as a failsafe of another, newer, dead one, and because of that it has many old and valuable programs installed, many of which I do not have the installation CD anymore (lost it, or some friend lended it to me and I gave it back years ago etc). And besides, it contains a long history, that I wouldn't be able to reproduce exactly even if I wanted to. I still haven't tried to install an OS on the new drive to see if that fails too, maybe I will try. But still, maybe someone here knows why this new hard drive is causing so much complications...

  2. #2
    Join Date
    May 2004
    arch linux
    Hello and welcome!

    Try using FSArchiver to create an archive that you can then restore to your new drive. You can go ahead and create the partitions on the new drive, and partition size won't matter as long as they are big enough to hold the expanded archive. Then use FSArchiver to restore your archive(s) to the new drive partitions.

    It's a command line tool so you'll need to know the commands to be used before starting, or have them printed out somewhere for reference purposes. I run FSArchiver from the PartedMagic LiveCD by booting the liveCD, then opening a terminal and running the necessary commands. You can also place simple text cheat-sheet with the commands somewhere on the drive you'll be working with and access it with the text editor on the liveCD, if needed.

    Note that you'll need to restore your bootloader to the new drive as a separate process. You can do that by any means you are familiar with, or you could even use your TrueImage liveCD to do it.

    I've used FSArchiver hundreds of times and it has never failed me yet. Of course, I do use it on Linux filesystems, but I believe it should work on Windows filesystems as well.

    Good luck with your task.

  3. #3
    Thank you for your quick reply. You are right, maybe the good way was not to look for a lower-level copy, but indeed for a higher level one. All I hope is that, at the end of the process, programs that were installed on the original partition will still run correctly, although files have been moved and have a different physical adress on the drive. I will try it! When done - or if any unexpected and unsolvable problems show up, as they usually do - I will come back!
    Thanks again


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts