Find the answer to your Linux question:
Results 1 to 3 of 3
HP 1000 j110a printer worked fine until it ran out of black ink at end of Oct. Took awhile to get a replacement. Installed and hp-levels shows black is 100%; ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Mar 2008
    Posts
    287

    hp 1000 printer fails to 5012 message


    HP 1000 j110a printer worked fine until it ran out of black ink at end of Oct. Took awhile to get a replacement. Installed and hp-levels shows black is 100%; color OK.
    Ever since I put in the new cartridge it has not printed a single page but everything shows up in queue (lpq -a).
    If I print from firefox 4.0 I get: Device Communications Error 5012
    If I print from command line the error is: Unable to communicate with device (code=12)
    I see a lot of error 5012 stuff on the web but nothing relating to the hp1000 deskjet.
    I tried restarting cups (1.4.6) with no change.
    Tried clearing queue then printing but still same.
    /etc/cups.conf and /etc/printers.conf are empty but may be meaningless.
    System is Slackware 13.37 and hplip which comes with the installation is 3.11.3a.
    Has this happened to others ? am I looking in the wrong place for the right file to fix?
    PS
    hp-check.log shows
    hp-check[2399]: info: :
    Initializing. Please wait...
    error: User exit
    hp-check[2399]: info: :
    hp-check[2399]: info: one.
    Last edited by clickit; 12-05-2011 at 05:02 AM.

  2. #2
    Linux Engineer MASONTX's Avatar
    Join Date
    May 2010
    Location
    Mason Texas
    Posts
    934
    I use an HP 1505 at work, and we have a similar problem all the time. Our fix is to unplug and turn off the printer, clear the print que, then replug and restart the printer and clear the error by pressing the flashing button. On occaision we have to do it 2 or 3 times to get it printing again.
    Registered Linux user #526930

  3. #3
    Linux User
    Join Date
    Mar 2008
    Posts
    287

    hp 1000 printer fails to 5012 message

    MASONTX thanx a bunch !!
    I did not want to believe UR solution at first and still would like a totally software fix solution but none the less it does work. Is this possibly why HP is getting out of computer? Makes 1 wonder.
    FWIW i intend to run hp-info -i when it is working and see if there is a difference if it fails again. That may provide an avenue to a software fix.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •