Find the answer to your Linux question:
Results 1 to 5 of 5
I am using fc16 and tried to install nvidia driver for gforce 210.Afetr installing my x windows stop working.Please help me to get out of this problem....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011
    Posts
    8

    NVIDIA (GForce210)Driver problem in fc16


    I am using fc16 and tried to install nvidia driver for gforce 210.Afetr installing my x windows stop working.Please help me to get out of this problem.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,307
    Hey,

    when you say you tried to install the nvidia driver, do you mean the one from nvidia.com or the one from Fedora repos? Whichever, you did, do the other.

    e.g., you can reinstall the Fedora driver with:

    Code:
    yum install xorg-x11-drv-nouveau
    if it complains that it is already installed, try this first:

    Code:
    rpm -e  xorg-x11-drv-nouveau
    then do the above yum command.

  3. #3
    Just Joined!
    Join Date
    Dec 2011
    Posts
    8

    fc16 nvidia driver problem

    I tried as suggested by you, following were the results
    #yum install xorg-x11-drv-nouveau
    Loaded plugins: langpacks, presto, refresh-packagekit
    adobe-linux-i386 | 951 B 00:00
    rpmfusion-free | 2.7 kB 00:00
    rpmfusion-free-updates | 3.3 kB 00:00
    rpmfusion-free-updates/primary_db | 117 kB 00:02
    Setting up Install Process
    Package 1org-x11-drv-nouveau-0.0.16-27.20110720gitb806e3f.fc16.i686 already installed and latest version
    Nothing to do
    [root@localhost ~]# rpm -e xorg-x11-drv-nouveau
    error: Failed dependencies:
    xorg-x11-drv-nouveau is needed by (installed) xorg-x11-drivers-7.4-2.fc15.i686
    [root@localhost ~]# rpm -e xorg-x11-drv-nouveau
    error: Failed dependencies:
    xorg-x11-drv-nouveau is needed by (installed) xorg-x11-drivers-7.4-2.fc15.i686

    please suggest what to do.
    I got the driver from the company site.
    I am accessing my system from another desktop on same fc16 as normally it telling after booting" contact your system administrator"
    I went there by pressing ctrl+alt+ F2 key and went to init 3 then started startx.
    Please suggest if did any thing wrong.

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,307
    i forgot about dependencies...try this:

    Code:
    rpm -e --nodeps xorg-x11-drv-nouveau
    then re-install it:

    Code:
    yum install xorg-x11-drv-nouveau
    I got the driver from the company site.
    What company is that? NVidia? That is the other way to go, trying to install their binary driver. It is a pretty straight-forward affair:

    1. download driver (try here)
    2. boot into runlevel 3
    3. run the installer (e.g., sh NVIDIA-Linux-x86-290.10.run)
    4. follow the instructions in the installer, then reboot

    The installer will require the kernel sources, so you'll need them. You can get them with:

    Code:
    yum install kernel-devel kernel-headers
    (or possibly the PAE version of the above, depending on your kernel).

    If you have problems with either method, post exactly what you tried and your exact error messages.

  5. #5
    Just Joined!
    Join Date
    Dec 2011
    Posts
    8

    fc16 nvidia driver problem

    I tried the same procedure as given in Nvidia site.I downloaded Nvidia-linux.285.05.09.run file then went to init 3 level then run the command sh Nvidialinux-.285.05.09.run .After rebooting the system It started displaying message " Oh something is wrong with the system and can not recover, contact system administrator.
    After that tried that procedure that I explained u earlier to enter into the system to try things further.i.e ctrl+alt+F2 to move to tty2 screen.
    I affraid to try for new driver which u sugested whether it may leave me to nothing doing state.
    Last edited by dineshbij75; 12-31-2011 at 04:31 PM. Reason: forgot something to tell It is not detecting my monitor thus I am getting very poor resolution..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •