Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hey all! I've posted this question somewhere else, and to this day have not gotten any response. So I'll try here. Now, I installed FUSE for exFAT and scons(if it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2012
    Posts
    16

    Weird exFAT mount error (EOD entry)


    Hey all!
    I've posted this question somewhere else, and to this day have not gotten any response. So I'll try here.

    Now,
    I installed FUSE for exFAT and scons(if it has much relevancy, I found a script in another thread and tried using it. Unfortunately it didn't work ).

    And, well, I try to mount the exFAT partition (sdd1) via shell into the mountpoint 'media/name_WD'. And this happens:

    Code:
    root@ubuntu:/mount -t exfat-fuse /dev/sdd1 name_WD
    FUSE exfat 0.9.6
    ERROR: missing EOD entry (0x20000, 0x20000). 
    root@ubuntu:

    This is really strange. I have gotten it to work once, but then I changed back to XP and updated Ubuntu Linux with apt-get-updgrade a little when I returned to the ubuntu partition. Ever since it has not worked for some odd reason, and I've been getting that stupid error!

    Anyone here to help me out?
    thanks!

    OS: Ubuntu Oneiric Ocelot

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    I've never used a disk formatted with exFat, isn't that a special Filesystem that Windows made just for USB disks?

    Anyway, this is not an answer to your problem, but is it possible to just format the disk with regular old FAT?, e.g.:

    Code:
    mkfs.vfat /dev/sdd1
    after having made backups, of course...

  3. #3
    Just Joined!
    Join Date
    Jan 2012
    Posts
    16
    Unfortunately, I need the exFAT filesystem on it. FAT only supports up to 4 GB. I have files larger than that, and it needs to work with windows and mac.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    ah, okay. well, how about reformatting it with exFAT using Linux tools? I see the utility mkexfatfs is available in the exfat-utils package. I downloaded it for Fedora 16 from here. Maybe that would make a difference?

  6. #5
    Just Joined!
    Join Date
    Jan 2012
    Posts
    16
    Quote Originally Posted by atreyu View Post
    ah, okay. well, how about reformatting it with exFAT using Linux tools? I see the utility mkexfatfs is available in the exfat-utils package. [/URL]. Maybe that would make a difference?
    Do you think this is the only way it'll work again?
    I really wish not to format it if possible.

  7. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    What about reformatting it with ntfs? I assume you are running some current Windows (XP or later) operating system which is why you want the exFAT partition, correct? If you are only going to use it with Linux, then format it with ext3 or ext4.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  8. #7
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,025
    Quote Originally Posted by Ryupower View Post
    Do you think this is the only way it'll work again?
    I really wish not to format it if possible.
    Would it be possible for you to copy the data, then format the drive, and restore the data?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  9. #8
    Just Joined!
    Join Date
    Jan 2012
    Posts
    16
    Quote Originally Posted by jayd512 View Post
    Would it be possible for you to copy the data, then format the drive, and restore the data?
    It would be possible, but it is a LOT of data and that would take a very long time. I'm trying to prevent formatting, as it is not guaranteed that it will change anything after I spend all the time copying.

    Quote Originally Posted by Rubberman View Post
    What about reformatting it with ntfs? I assume you are running some current Windows (XP or later) operating system which is why you want the exFAT partition, correct? If you are only going to use it with Linux, then format it with ext3 or ext4.
    I'm actually using Linux, Windows, and Mac OSX. Mac OSX can read and write NTFS with Mac-FUSE installed, but to do this at my college Macs I'd have to have administrator privs, which I don't because I'm just a student.

  10. #9
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by Ryupower View Post
    Do you think this is the only way it'll work again?
    I really wish not to format it if possible.
    I have no idea if that is the only way (in fact, I'm sure it is not). To be honest, I don't even know if that would work...I'm just shooting spit-wads and seein' what will stick.

    but just curious, why is reformatting such an undesirable option?

  11. #10
    Just Joined!
    Join Date
    Jan 2012
    Posts
    16
    Quote Originally Posted by atreyu View Post
    I have no idea if that is the only way (in fact, I'm sure it is not). To be honest, I don't even know if that would work...I'm just shooting spit-wads and seein' what will stick.

    but just curious, why is reformatting such an undesirable option?
    hey,
    it's so time consuming because I have huge files on it, and it is not guaranteed that I won't get that error again if I do.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •