Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
hi i have this problem that my SSD stopped working in windows but im able to view it with Linux GParted distro. now, assuming its somewhat broken im trying to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10

    retriveing data from ntfs ssd


    hi i have this problem that my SSD stopped working in windows but im able to view it with Linux GParted distro.
    now, assuming its somewhat broken im trying to backup my files.
    but when i selected mount from gparted i get this

    mount: /dev/sda3: can't read superblock

    any ideas instructions how to get data out from this ntfs based ssd

    thx

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,159
    Show ALL of the steps you used to try to mount this device.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    Quote Originally Posted by Rubberman View Post
    Show ALL of the steps you used to try to mount this device.
    you know it was just right click from qparted at the ntfs partition and -> "mount to"

    then i get that error

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,159
    1. Unmount the device.
    2. Run fsck on the device's file system entry (such as /dev/sdb1): umount /dev/sdb1 ; fsck -f /dev/sdb1

    The "bad superblock" message is telling you that something has munged the file system on that device and that you need to fix it, which the fsck command will do, but you need to do that on an unmounted partition as shown above.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    tried that but got error:

    Code:
    umount: /dev/sda3: not mounted
    fsck 1.41.14 (22-Dec-2010)
    fsck: fsck.ntfs-3g: not found
    fsck: Error 2 while executing fsck.ntfs-3g for /dev/sda3

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,159
    You need the ntfsprogs package which has the fsck.ntfs (link to ntfsck). If it still complains about needing fsck.ntfs-3g, then as root (or sudo) create a link in /sbin from ntfsck to fsck.ntfs-3g.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #7
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    ok i was able to run the fsck command but when i try to mount i get "bad superblock" error again.
    fsck command didnt report anything put date.

  8. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,159
    Try running fsck again on the unmounted file system, but use the -f (force) option so even if the file system appears clean, it will still do a full scan/repair. Also, have you tried mounting it on a Windows system to see what it thinks of the drive?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  9. #9
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    i did use the -f flag...

    cant get to windows with it.

  10. #10
    Just Joined!
    Join Date
    Feb 2012
    Posts
    10
    i had to also use symlink like this, wonder if its correct?

    Code:
    ln -s -b /usr/sbin/ntfsck /sbin/fsck.ntfs-3g

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •