Find the answer to your Linux question:
Results 1 to 10 of 10
I Installed a graphics card (nvidia) because I wanted to use two monitors. Prior to this I was using the motherboard socket and my display was working fine. I put ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5

    Question New graphics card now system does not recognise motherboard graphics




    I Installed a graphics card (nvidia) because I wanted to use two monitors. Prior to this I was using the motherboard socket and my display was working fine. I put in the new card and installed the nvidia drivers. Now my system only sees the new card. When I search the web all references to this problem say that I should go into administration and ask the configuration tool to 'detect monitors'. I have done that and it makes no difference. It is as if there is only one graphics port on my system. If I take the card out my motherboard socket works again. How do I get my system to recognise and use both graphics facilities so that I can use a dual monitor?

    Regards,

    Matthew

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,934
    It is likely that the BIOS will disable the on-board video if you plug in a video card. There may be an option in your BIOS to enable both video chipsets, but if there isn't then you're probably stuck. You may find that having two video cards in the system like this causes all kinds of video driver headaches anyway. Does your new video card have two outputs on it (even if they're different types like HDMI and VGA)? This might be an easier way to get the system working on two monitors.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5
    Thx Roxoff. After reading your post I found a setting in the BIOS and now the system recognises the second screen. It switches it on and gives me a black screen with a cursor in the top left corner.

    I have tried 'detect monitors' in monitor preferences but it does not acknowledge that there is a second monitor. Is there any other way to get the OS to detect and use the second monitor?

    In terminal I get:

    Code:
    lspci |grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
    01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)
    Last edited by strigan; 07-25-2012 at 08:00 PM.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,934
    It's good that both your video cards are now detected. To get this working, you're probably going to have to craft your own xorg.conf file. Don't worry overly about this, it's not hard - it's just a text file that tells the X graphics system where to put each screen and which drivers to use. These days the file isn't normally needed because X is pretty good at detecting and auto-configuring video. But you're asking for something that is a little unusual.

    The best source of information is the xorg.conf manual page, but that's a reference rather than a how-to.

    I found some more information that may be in a more readable format on the Gentoo wiki. You don't say which distribution you're using, but this information is pretty standard config stuff that should apply to all distributions. The tools it mentions may or may not be available, though (you'll have to check in your own package manager).
    Linux user #126863 - see http://linuxcounter.net/

  6. #5
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    124

    Another solution.

    Quote Originally Posted by strigan View Post


    I Installed a graphics card (nvidia) because I wanted to use two monitors. Prior to this I was using the motherboard socket and my display was working fine. I put in the new card and installed the nvidia drivers. Now my system only sees the new card. When I search the web all references to this problem say that I should go into administration and ask the configuration tool to 'detect monitors'. I have done that and it makes no difference. It is as if there is only one graphics port on my system. If I take the card out my motherboard socket works again. How do I get my system to recognise and use both graphics facilities so that I can use a dual monitor?

    Regards,

    Matthew
    You may also forget about your inboard Intel graphics, and use the 2 video outputs you must have on your nvidia card. With the proprietary nvidia driver, configuring the both displays with NVIDIA-SETTINGS is now trivial, and you don't need to handcraft your own /etc/X11/xorg.conf

  7. #6
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5
    Thx - so I bought an HDMI to VGA cable and fitted it so that both monitors are connected to the card I have installed (one in the HDMI socket and one in the VGA). Nvidia-settings picks up both monitors and allows me to configure them. The monitor plugged into the HDMI cable has no picture - it has a 'Check Signal Cable' message on it as if it is not connected but nvidia-settings picks it up and correctly names it as a Samsung screen. Anyway after configuring them with nvidia-settings and restarting X (I also tried a reboot) there is no change - the screen connected to the HDMI cable is not getting a picture.

    PS: I am using LinuxMint release 13 (maya) Linux 3.2.0-23-generic.

    xorg.conf as configured Nvidia:
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 295.33  (buildd@zirconium)  Fri Mar 30 13:38:49 UTC 2012
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "hp f1523"
        HorizSync       30.0 - 61.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "Samsung SyncMaster"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 210"
        BusID          "PCI:1:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 210"
        BusID          "PCI:1:0:0"
        Screen          1
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "CRT: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen1"
        Device         "Device1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "DFP: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

  8. #7
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    124
    Hi.

    At first, you must remove from this XORG.CONF the "ServerLayout" and "InputDevice" parts, for they are auto config.
    Then for your monitors, it is likely a refresh rate problem. Check both of them separately. You may have to exchange them, depending on your connexions. I can see you used "separate X screen" option, but the "serverlayout" is ignored in /etc/X11/xorg.conf. You should use the TWINVIEW option. Your server section will look like this :

    Code:
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-1"
        Option         "metamodes" "DFP-1: nvidia-auto-select +0+0, DFP-0: nvidia-auto-select +1920+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    .

  9. #8
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5

    Question

    So I bought a DVI to VGA adapter and have plugged both monitors into the card. I am using xinerama and it is working well. I have one problem. I have a Samsung Syncmaster 1440x900 display and a Hewlett Packard pavillion f1523 1024x768 display. My system always assumes that my old HP monitor is my main display - it seems to assume that the monitor plugged into the DVI socket is the main screen. If I swap that plugs and plug the Syncmaster into the adapter (DVI) I am not allowed to use 1440x900 for the Syncmaster - it ignores me and makes them both 1024x768 - distorting the image on the Syncmaster. How do I get Linux to use my Syncmaster as me main screen? I have looked in my bios settings and haven't found anything there.

    xorg.conf:
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 295.33  (buildd@zirconium)  Fri Mar 30 13:38:49 UTC 2012
    
    
    Section "ServerLayout"
    # Removed Option "Xinerama" "0"
        Identifier     "Layout0"
        Screen      0  "Screen0" RightOf "Screen1"
        Screen      1  "Screen1" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "1"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "true"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: xconfig, VertRefresh source: xconfig
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "CRT-0"
        HorizSync       30.0 - 61.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "Samsung SyncMaster"
        HorizSync       30.0 - 81.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 210"
        BusID          "PCI:1:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 210"
        BusID          "PCI:1:0:0"
        Screen          1
    EndSection
    
    Section "Screen"
    # Removed Option "metamodes" "CRT-0: 1440x900 +0+0; CRT-0: nvidia-auto-select +0+0"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "CRT-0: 1024x768_60 +0+0; CRT-0: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
    # Removed Option "metamodes" "CRT-1: nvidia-auto-select +0+0"
        Identifier     "Screen1"
        Device         "Device1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "CRT-1: 1440x900 +0+0; CRT-1: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Disable"
    EndSection

  10. #9
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    124
    Still using "separate X screen". Use the "Twinview" option in nvidia-settings ; read my previous post. And DON'T use the xinerama option : that's beause your 2 screens are locked at the same resolution.
    Last edited by CaptainDangeax; 08-01-2012 at 02:20 PM. Reason: forgot something

  11. #10
    Linux Newbie mactruck's Avatar
    Join Date
    Apr 2012
    Location
    City of Salt
    Posts
    187
    when you go into monitor preferences, see if there is a button that says "mirror display" if there is then turn that off. Once you do that you should be able to see both as a separate monitor. I also had this same issue with Mint but now its fixed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •