Find the answer to your Linux question:
Results 1 to 4 of 4
I have a 4 gig usb stick ive been having issues with after writing zorin to it for a friend it wont wipe clean or mount Gparted and cfdisk cant ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! ltnemo2000's Avatar
    Join Date
    Jun 2012
    Location
    a day's walk west of chicago
    Posts
    26

    More USB device issues


    I have a 4 gig usb stick ive been having issues with
    after writing zorin to it for a friend it wont wipe clean or mount
    Gparted and cfdisk cant seem to put a new partition table on it
    when I ran:
    dd if=/dev/zero of=/dev/sdb bs=512 count=1
    it had no effect on the zorin images on there
    the same problem happened to my usb hard disk
    the images wont come off with dd, gparted or cfdisk

    well, my own stuff aside, heres the result of $mount:
    Code:
    /dev/sdb1 on /media/Zorin OS 5.2 64bit type iso9660 (ro,nosuid,nodev,relatime,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks)
    /dev/sdb1 on /media/Zorin OS 5.2 64bit_ type iso9660 (ro,nosuid,nodev,relatime,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks)
    /dev/sdb1 on /media/Zorin OS 5.2 64bit___ type iso9660 (ro,nosuid,nodev,relatime,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks)
    I noticed that the capacity of my device is about 300B for the stick and 93 for the HD.
    how can I clean these off?

  2. #2
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225
    First, check this: a very few USB sticks out there have a write-protect slider on them. If you have one of these, make sure the slider is up (toward the contacts). This tutorial shows how to format a USB stick: Restore Your USB Key to it's original state | USB Pen Drive Linux

  3. #3
    Linux Newbie
    Join Date
    Jun 2012
    Location
    SF Bay area
    Posts
    151
    First, checking the write-protect slider is a great catch! I forgot some USB devices had that feature.

    Second, if you remove the "count=1" from the "dd" command it should wipe out everything on the disk. But if "gparted" won't write to the device that's pretty odd. Are you sure it's not getting mounted by your OS? I never tried to run "gparted" or any of the "fdisk" family of commands on the device that was mounted by the OS. I would expect those tools to baulk at wiping out the partition on device that the OS was actively using. The "/media/Zorin" bit above is what prompted me to ask about it being mounted. If that's the case, just "umount /media/Zorin" before running "gparted".

    Also, in case you want other commands to try, you can repartition devices with "palimpsest" too if it's on your system. That's the command line to invoke the standard disk manager on Ubuntu and Fedora systems. It has a pretty clean, straightforward UI and might give you more info to help diagnose the problem even if it doesn't work.
    Last edited by cnamejj; 08-04-2012 at 06:25 AM. Reason: typo, grammar mistake

  4. #4
    Linux Newbie
    Join Date
    Oct 2008
    Posts
    151
    You'll have to unmount it first. Try this
    Code:
    su -c "umount /media/Zorin"
    It'll ask you for the root password, after which you shoul be able to run gparted.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •