Find the answer to your Linux question:
Page 4 of 4 FirstFirst 1 2 3 4
Results 31 to 32 of 32
Are you using the full path to shutdown (i.e., /sbin/shutdown) in your SHUTDOWNCMD? Yes Atreyu, I'm using the full path to shutdown command You are correct I should not use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Linux Newbie amithad's Avatar
    Join Date
    Sep 2006
    Location
    Sri Lanka
    Posts
    160

    Are you using the full path to shutdown (i.e., /sbin/shutdown) in your SHUTDOWNCMD?
    Yes Atreyu, I'm using the full path to shutdown command

    You are correct I should not use that "POWERDOWNFLAG "/sbin/shutdown -P +0" in the upsmon.conf file.

    When I try the upsmon -c fsd with my current confuguration it gave the following output

    Code:
    [root@proxy ~]# upsmon -c fsd
    Network UPS Tools upsmon 2.6.5
    kill: No such process
    After commenting the POWERDOWNFLAG "/sbin/shutdown -P +0" line and re-enabling the POWERDOWNFLAG /etc/ups/killpower line and executing upsmon -c fsd command, I was able to shutdown the server

    Code:
    [root@proxy ups]# upsmon -c fsd
    Network UPS Tools upsmon 2.6.5
    [root@proxy ups]#
    Broadcast message from nut@proxy.server (Wed Nov 14 17:49:52 2012):
    
    UPS 3000@localhost: forced shutdown in progress
    
    Broadcast message from nut@proxy.server (Wed Nov 14 17:50:04 2012):
    
    Executing automatic power-fail shutdown
    
    
    Broadcast message from nut@proxy.server (Wed Nov 14 17:50:04 2012):
    
    Auto logout and shutdown proceeding
    
    Broadcast message from nut@proxy.server (Wed Nov 14 17:50:08 2012):
    
    Executing automatic power-fail shutdown
    
    
    Broadcast message from nut@proxy.server (Wed Nov 14 17:50:08 2012):
    
    Auto logout and shutdown proceeding
    
    Broadcast message from root@proxy.server
            (unknown) at 17:50 ...
    
    The system is going down for power off NOW!
    
    Broadcast message from root@proxy.server
            (unknown) at 17:50 ...
    
    The system is going down for power off NOW!
    but the five minute setting is the one that hard to achive

  2. #32
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by amithad View Post
    but the five minute setting is the one that hard to achive
    Again, quoting the upsmon.conf man page:

    FINALDELAY seconds

    When running in master mode, upsmon waits this long after sending the NOTIFY_SHUTDOWN to warn the users. After the timer elapses, it then runs your SHUTDOWNCMD. By default this is set to 5 seconds.

    So have you tried setting FINALDELAY to 300 in your conf file?

Page 4 of 4 FirstFirst 1 2 3 4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •