Find the answer to your Linux question:
Results 1 to 7 of 7
Hi gurus, I am trying make wireless card working but I am stuck. Tried following: Hardware button for wifi is enabled (wifi led lights): Code: [root@HP-PC ~]# modprobe -r iwl3945 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2009
    Posts
    70

    HP Compaq 6710 - Intel(R) PRO/Wireless 3945ABG/BG


    Hi gurus,
    I am trying make wireless card working but I am stuck. Tried following:

    Hardware button for wifi is enabled (wifi led lights):
    Code:
    [root@HP-PC ~]# modprobe -r iwl3945
    [root@HP-PC ~]# modprobe iwl3945
    
    [root@HP-PC ~]# ifconfig wlan0 up
    SIOCSIFFLAGS: No such device
    
    [root@HP-PC ~]# ifup wlan0
    /sbin/ifup: configuration for wlan0 not found.
    Usage: ifup <device name>
    
    [root@HP-PC network-scripts]# dmesg | tail -n 30
    [ 2044.351583] iwl3945 0000:10:00.0: loaded firmware version 15.32.2.9
    [ 2044.351717] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
    [ 2044.353597] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
    [ 2044.353840] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
    [ 2642.444831] cfg80211: Calling CRDA to update world regulatory domain
    [ 2642.458065] cfg80211: World regulatory domain updated:
    [ 2642.458068] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 2642.458072] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 2642.458075] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 2642.458077] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 2642.458080] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 2642.458083] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 2642.458570] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:ds
    [ 2642.458572] iwl3945: Copyright(c) 2003-2011 Intel Corporation
    [ 2642.499392] iwl3945 0000:10:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
    [ 2642.499395] iwl3945 0000:10:00.0: Detected Intel Wireless WiFi Link 3945ABG
    [ 2642.499546] iwl3945 0000:10:00.0: irq 46 for MSI/MSI-X
    [ 2642.499755] Registered led device: phy0-led
    [ 2642.499917] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
    [ 2642.514681] cfg80211: Calling CRDA for country: SK
    [ 2642.530901] cfg80211: Regulatory domain changed to country: SK
    [ 2642.530905] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 2642.530908] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [ 2642.530911] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [ 2642.530913] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [ 2642.530916] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
    [ 2642.582149] iwl3945 0000:10:00.0: loaded firmware version 15.32.2.9
    [ 2642.582286] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
    [ 2642.584171] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
    [ 2642.584380] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch



    Hardware button for wifi is disabled (wifi led is grey):

    Code:
    [root@HP-PC ~]# modprobe -r iwl3945
    [root@HP-PC ~]# modprobe iwl3945
    
    [root@HP-PC ~]# ifconfig wlan0 up
    SIOCSIFFLAGS: Operation not possible due to RF-kill
    
    [root@HP-PC ~]# ifup wlan0
    /sbin/ifup: configuration for wlan0 not found.
    Usage: ifup <device name>
    
    [root@HP-PC ~]# dmesg | tail -n 30
    [ 2990.504120] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [ 2990.504122] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
    [ 2990.546605] iwl3945 0000:10:00.0: loaded firmware version 15.32.2.9
    [ 2990.546734] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
    [ 2990.548546] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
    [ 2990.548821] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
    [ 3125.283057] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
    [ 3241.454124] usb 3-1: USB disconnect, device number 4
    [ 3250.626608] cfg80211: Calling CRDA to update world regulatory domain
    [ 3250.633326] cfg80211: World regulatory domain updated:
    [ 3250.633329] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 3250.633332] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 3250.633335] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 3250.633338] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 3250.633341] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 3250.633343] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 3250.639383] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:ds
    [ 3250.639386] iwl3945: Copyright(c) 2003-2011 Intel Corporation
    [ 3250.680265] iwl3945 0000:10:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
    [ 3250.680270] iwl3945 0000:10:00.0: Detected Intel Wireless WiFi Link 3945ABG
    [ 3250.680432] iwl3945 0000:10:00.0: irq 46 for MSI/MSI-X
    [ 3250.680639] Registered led device: phy0-led
    [ 3250.680788] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
    [ 3250.699498] cfg80211: Calling CRDA for country: SK
    [ 3250.705479] cfg80211: Regulatory domain changed to country: SK
    [ 3250.705483] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 3250.705486] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [ 3250.705489] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [ 3250.705491] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [ 3250.705494] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)

    Also in both cases tried:
    Code:
    [root@HP-PC ~]#  rfkill unblock all


    This seems weird because AFAIK "Radio disabled by HW RF Kill switch" means that wifi is disabled by hardware swtich. But this message appers in dmsg when hardware switch was on.

    CONFIGURATION:

    PC:
    HP Compaq 6710b

    WLAN Card:
    Code:
    [root@HP-PC network-scripts]# iwconfig 
    p3p1      no wireless extensions.
    
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11abg  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:on
    Code:
    [root@HP-PC network-scripts]# lshw -C network
      *-network DISABLED      
           description: Wireless interface
           product: PRO/Wireless 3945ABG [Golan] Network Connection
           vendor: Intel Corporation
           physical id: 0
           bus info: pci@0000:10:00.0
           logical name: wlan0
           version: 02
           serial: 00:1c:bf:2f:9d:e1
           width: 32 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=iwl3945 driverversion=3.4.11-1.fc16.x86_64 firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11abg
           resources: irq:46 memory:e4100000-e4100fff
    Code:
    [root@HP-PC network-scripts]# lspci  | grep Wireless
    10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)


    Software:
    Code:
    [root@HP-PC network-scripts]# uname -a
    Linux HP-PC 3.4.11-1.fc16.x86_64 #1 SMP Sun Sep 16 13:50:06 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    [root@HP-PC network-scripts]# cat /etc/redhat-release 
    Fedora release 16 (Verne)

    HP Compaq 6710 - Intel(R) PRO/Wireless 3945ABG/BG

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,144
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined!
    Join Date
    Jul 2009
    Posts
    70
    Thank you, I will try ASAP and report

  4. #4
    Just Joined!
    Join Date
    Jul 2009
    Posts
    70
    unfortunatelly did not help, any other ideas ? is somehow possible to check if wireless NIC is not physically damaged ?

  5. #5
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,144
    Quote Originally Posted by wakatana View Post
    unfortunatelly did not help, any other ideas ? is somehow possible to check if wireless NIC is not physically damaged ?
    The wireless card seems OK. No damage seen, The hard block is a wireless key issue. My suggestion is to boot a newer fedora live cd

    Fedora Project - Download Fedora and try it.

    and see if hard block is still in effect running live. Your wireless key may be malfunctioning. Other than that. A wireless bios setting may need to be changed.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  6. #6
    Just Joined!
    Join Date
    Jul 2009
    Posts
    70
    I am not so shure about hardware damage. Also seems that problem is also on W7, neither windows nor netstrumbler software simply wont scan netowrks. Netstrumbler also report some error message regarding adapter. In windows seems that everything is installed, I tried also download official drivers from intel on windows, no luck. What do you mean by bios setting changing ? Some kind of firmware flashing ? Will try live fedora ASAP. Regards

  7. #7
    Just Joined!
    Join Date
    Jul 2009
    Posts
    70
    Problem solved
    LAN/WLAN switching have to be turned off in the BIOS settings
    HP-Compaq 6710B [LinLap - Linux Laptop Wiki]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •