Find the answer to your Linux question:
Results 1 to 4 of 4
I am doing some system maintenance after updating my X server and I ran across an problem with my Bluetooth adapter that i just can not figure out and apparently ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2012
    Posts
    129

    USB Disconnect Reconnect Endless Loop


    I am doing some system maintenance after updating my X server and I ran across an problem with my Bluetooth adapter that i just can not figure out and apparently is a problem with my debian distro but i followed their solution to reinstall all the drivers and firmware yet it did not work

    I have an asus USB-BT211 which is really just an Atheos AR3011 and uses the Ath3k module.

    However I noticed that flooding the tail of my messages log is the following statement block regarding my AR3011

    Code:
    Feb 24 04:46:42 Caesar kernel: [ 1029.139183] usb 2-1.1: new full-speed USB device number 40 using ehci_hcd
    Feb 24 04:46:42 Caesar kernel: [ 1029.231376] usb 2-1.1: New USB device found, idVendor=0cf3, idProduct=3000
    Feb 24 04:46:42 Caesar kernel: [ 1029.231378] usb 2-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
    Feb 24 04:46:42 Caesar kernel: [ 1029.473859] usb 2-1.1: USB disconnect, device number 40
    This loop cycles every 30 second. When it starts at bootup the device number is 6 and after 5 /7 minutes to type this its already reached forty. Has anyone ever come across a solution to this

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    I'd try this:
    1. Disconnect BT adapter
    2. Use modprobe (as root/sudo) to remove the atheros driver
    3. Reboot
    4. Plugin BT adapter
    5. Check with lsusb that it is recognized by system
    6. Install latest version of the appropriate driver
    7. Cross fingers


    Sorry, but I don't have any magic flooby dust to fix this other than trying from a blank slate, so to speak, as shown.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Linux Newbie
    Join Date
    Apr 2012
    Posts
    129
    That worked almost ive found a small hang up again that might be impeding my connection via bluetooth.

    I execute /etc/init.d/bluetooth status which returns it as running and I have set my bluetooth device to active broadcast yet I can not seem to detect my phone nor can my phone detect my pc.

    So i check my syslog for error messages and i run across these 4

    Feb 24 19:42:57 Caesar bluetoothd[1524]: Failed to find Bluetooth netlink family
    Feb 24 19:42:57 Caesar bluetoothd[1524]: Failed to init netlink plugin
    Feb 24 19:42:57 Caesar bluetoothd[1524]: Failed to open RFKILL control device
    Feb 24 19:42:58 Caesar bluetoothd[1524]: Failed to access HAL

    From what I can understand those all relate to using bluetooth to tether a phone in order to get internet access except for the last one relating to the HAL i have no clue what that means in context. I searched each term and i got lists of old bug reports so i do not know if this is a problem preventing connection or some other error

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Apr 2012
    Posts
    129
    Actually I was incorrect somehow my driver broke again from when i shut down my machine to when I logged on the next day. I have exhausted all options i can think of and I have recompiled my kernel atleast 15 times disabling each option with bluetooth except the option to recognized a usb bluetooth device before realizing that what i was doing was pointless. I reinstalled my bluez stack which did not help and I tried manually adding the firmware to my /lib/firmware directory.

    From what I can tell if the atheros ath3k.ko modules was inserted into the kernel at boot time without the ath3k-1.fw file in my /lib/firmware directory I would receive a bunch of error messages with the off chance that the error locks up my entire USB hub making my system unusable until i remove the device. If I have the ath3k.ko module and the ath3k-1.fw installed at the same time i get stuck in that weird disconnect reconnect endless loop. If i remove the ath3k.ko from compiling and recompiling my kernel. I receive no errors and all the usb devices show up however I can not use my bluetooth.

    What I can not seem to recreate is what ever I did yesterday that actually made it work where I could see my bluetooth devices or the specific error message that I got earlier today that broke what i did yesterday.

    One other things of note. Im running a customized (admittedly rather amateurish but stable) 3.2 kernel Im betting that the ath3k driver might have been improved but I do not know if it has been backported to the 3.2 branch is it possible to compile a module from a newer kernel without creating dependency issues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •