Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I just bought this wireless usb adapter and I am having some problems making it work on my laptop. For some reason the device is labelled as unresponsive, as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2013
    Posts
    2

    Tl-wn722n on Backtrack 5


    Hello, I just bought this wireless usb adapter and I am having some problems making it work on my laptop.

    For some reason the device is labelled as unresponsive, as the log below shows:

    (dmesg)
    [ 280.332694] usb 2-4: USB disconnect, device number 3
    [ 280.386825] usb 2-4: ath9k_htc: USB layer deinitialized
    [ 280.628182] usb 2-4: new high-speed USB device number 4 using ehci_hcd
    [ 281.032431] hub 2-0:1.0: unable to enumerate USB device on port 4
    [ 281.424175] usb 6-2: new full-speed USB device number 2 using uhci_hcd
    [ 281.590289] usb 6-2: not running at top speed; connect to a high speed hub
    [ 281.991291] usb 6-2: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
    [ 282.992167] ath9k_htc 6-2:1.0: ath9k_htc: Target is unresponsive
    [ 282.992182] Failed to initialize the device
    [ 283.065385] ath9k_htc: probe of 6-2:1.0 failed with error -22

    My internal wifi adapter works fine.

    And Tl-wn722n is correctly plugged:

    rootbt:~# lsusb
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 002: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
    Bus 002 Device 002: ID 04f2:b016 Chicony Electronics Co., Ltd VGA 30fps UVC Webcam

    I tried with different versions of backtrack, I tried powering off and turning it on with the adapter already in place, and I also tried installing the latest version of compat-drivers and htc_9271.fw and still nothing.

    I know that the problem doesn't come from backtrack, as I have it on another computer and it works as soon as I plug it in. The problem isn't in my hardware also as I just installed windows and the adapter works fine. So I can only assume the problem comes from the combination of backtrack and my hardware, which is a hp pavillion dv2700.

    Do you think this computer only works properly with windows?

    I hope you can help me, I'm new to linux, but I did a lot of research on this matter and found nothing.

  2. #2
    Just Joined!
    Join Date
    Mar 2013
    Posts
    2
    I am please to say that by chance I have found the solution for my problem: It seems that when I plug the adapter through a cheap usb hub that I just bought it works fine! Strange! And the irony of it is that I bought this device for better signalling and my stone age internal wireless adapter gets better signal than the Tl-wn722n "high gain" adapter. Anyway, it's a bit uncomfortable to walk around with a usb hub, so in case anyone has a theory of why a direct plug doesn't seem to work I would be glad to hear it. Thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •