Hi,


Recently, I think with kernel 3.6 (I use 3.7.10-gentoo), I started getting problems with my USB (Logitech radio) mouse whenever I am running off battery: it deactivates almost immediately, which means I constantly have to (literally) shake it to wake up from sleep before I can use it again. Typical mouse usage includes short periods of activity and longer periods of inactivity, so it is not as if I handle my mouse in a special way.

When looking at what happens:

Code:
# dmesg | tail
[ 4970.857253] ehci_hcd 0000:00:1a.0: setting latency timer to 64
[ 4970.857383] ehci_hcd 0000:00:1d.0: power state changed by ACPI to D0
[ 4970.958115] ehci_hcd 0000:00:1d.0: setting latency timer to 64
[ 4970.968985] ehci_hcd 0000:00:1d.0: power state changed by ACPI to D3cold
[ 4979.335879] ehci_hcd 0000:00:1a.0: power state changed by ACPI to D3cold
[ 5389.669794] ehci_hcd 0000:00:1a.0: power state changed by ACPI to D0
[ 5389.770291] ehci_hcd 0000:00:1a.0: setting latency timer to 64
[ 5389.770531] ehci_hcd 0000:00:1d.0: power state changed by ACPI to D0
[ 5389.871161] ehci_hcd 0000:00:1d.0: setting latency timer to 64
[ 5389.881955] ehci_hcd 0000:00:1d.0: power state changed by ACPI to D3cold
It becomes clear that USB (ehci_hcd) is switched from full power (D0) to sleep mode (D3cold) way too fast (in about a tenth of a second!).

I see different possible reasons for this behavior:
  1. Bug in the kernel I use.
  2. (Mis)configuration on my part becoming apparent after recent changes in the kernel.

I would be grateful if anyone could guide me to discover what the underlying problem is and help me find a workaround.


TIA,

Erik