Find the answer to your Linux question:
Results 1 to 7 of 7
I have 2 usb flash drives. One of them works just fine with regular command: mount -t vfat /dev/sda1 /mnt/usbflash However with the other one I get the following: debian:/proc/bus/usb# ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    8

    USB flashdrive problems


    I have 2 usb flash drives.
    One of them works just fine with regular command:
    mount -t vfat /dev/sda1 /mnt/usbflash

    However with the other one I get the following:
    debian:/proc/bus/usb# mount -t vfat /dev/sda1 /mnt/usbflash/
    mount: wrong fs type, bad option, bad superblock on /dev/sda1,
    or too many mounted file systems
    (aren't you trying to mount an extended partition,
    instead of some logical partition insid

    I know its a fat filesystem (from windows XP)

    Any Ideas?
    Thanks

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    how about not specifing the filesystem?
    Code:
    mount /dev/sda1 /mnt/usbflah

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    8
    No, says I must specify the filesystem:

    debian:/home/mike# mount /dev/sda1 /mnt/usbflash/
    mount: you must specify the filesystem type
    debian:/home/mike# mount -t auto /dev/sda1 /mnt/usbflash/
    mount: you must specify the filesystem type

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    you right, i forgot about that.....

    I really have no clue what the problem could be. Have you actually tried the usb drive in win to make sure it working correcty

  6. #5
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    The actual problem could be that it detected it, but didnt put it as sda1... are you sure it didnt detect it and placed it as sda2,3,4... if its different from the first, this might be your problem....

    here's a god tutorial on usb flash... that will get you on the go
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  7. #6
    Just Joined!
    Join Date
    Dec 2004
    Posts
    8
    debian:/home/mike# ls -l /dev/sd*
    brw-r----- 1 root hal 8, 0 2004-12-31 15:34 /dev/sda
    brw-r----- 1 root hal 8, 1 2004-12-31 15:34 /dev/sda1



    So I'm pretty sure the device is sda

  8. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    1

    possible fix...?

    Hey, I was having this same problem and I think I fixed it by making sure the iso-8859-1 (and 437) code pages were compiled into my kernel. I don't really understand why this would help, but I had an error message along these lines in my logs.

    Try doing a

    tail -f /var/log/(whatever your log file is)

    and then trying to mount on another terminal. any errors?

    pax,
    scott

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •