Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I'm tinkering with DSL (Damn Small Linux) which is a Knoppix-like. The problem is my mouse suddenly won't work. On prior installations of DSL it worked. This time, no ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2013
    Posts
    2

    Frozen mouse blues.


    Hi,

    I'm tinkering with DSL (Damn Small Linux) which is a Knoppix-like.
    The problem is my mouse suddenly won't work. On prior installations of DSL it worked. This time, no dice. It is recognized by the system as a Dell Mouse, but it is completely dysfunctional. I'm hoping for tips on making it work.

    After researching a bit, I tried to make it work by editing grub's menu.lst file in the KNOPPIX directory. I was trying to add "nofstab" to the file to get it to autoconfigure in the hopes that this would kickstart the mouse. What I discovered is that menu.lst is considered a read-only file and no amount of chmodding the file or using vi with :wq! or even :w !sudo tee % will make it save.

    So I guess I have two questions: 1. how to make a mouse work. 2. how to change a read only file when chmod and wq! don't work.

    Regards,

    dsl-numbe.

  2. #2
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    1. how to make a mouse work.
    Have you tried unplugging the mouse and then plug it back in?

    2. how to change a read only file when chmod and wq! don't work.
    Have you tried this from a terminal?
    Code:
     sudo <some editor> /path/to/menu.lst
    FWIW, I'd suggest leaving the system files owned by root alone and not changing ownership. Use sudo for root priviledges to edit those system config files. Tinkering with a system can be fun, except when it breaks... Good luck.

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    Is it possible the mouse is broken? Have you tried another distribution (via a Live CD/DVD/USB drive)?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •