Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all... I've tried to get this to work before and along with others have not received good and repeatable results. I have followed the original documentation for this and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    209

    Format of USB - unable to create 'mount point'



    Hi all... I've tried to get this to work before and along with others have not received good and repeatable results. I have followed the original documentation for this and it is not working. I have become very frustrated. So I thought I'd put in in front of the real wizzards, you!

    I have a Global Scale Technology Dreamplug (Plug Computer) that runs Debian. It requires that the initial load (Debian loader) exist in a VFAT file system. The image can reside in an ext type (ext2, ext3, etc) fs. So the problem is to create a USB sick with these properties.

    I have used all sorts of format software, in fact all that I can find via Google'ing the search. All have the pitfall of when you format the stick, you have to un mount it, when you go to mount it, you have to have a mount point. This is the catch 22 part of the operation. I can't properly mount the device without a mount point and I can't mount it to make the 'mount point'. This seems to be the problem.

    I was referenced to gparted, which seems to work until I get to the mount point problem. Most of the time the drop down menu has 'mount' greyed out. When it has been visible, I've tried to use it and let the software run over a 12 + hour time and it's still stuck in a loop with no results. Other format programs appear to do the same or don't offer a way to create this.

    I am pretty technical, sometimes this gets in the way of getting something done, so that's a worry at this point. All of the parts I've read about formatting a USB sick, quits before they get to mounting it. I need two mount points that, in my case are 'freedom' and 'boot' the boot references the 128 M vfat partition and the 'freedom' I believe is a reference to the whole device although it's actually referened as /dev/sde2 (/dev/sde1 for 'boot'). So the two mount points need to be /media/freedom and /media/freedom/boot. I don't know if the format has something to do with the order of the pathname.

    These options are burried down in the scripts that build the Debian OS image for the Dreamplug, and I don't have the knowledge to modify these scripts, as there are quite a number of them. This software actually builds the image for the Dreamplug, along with a file system and all the supporting binaries and support scripts for an operating system that is installed. After the boot on the Dreamplug you have a complete Debian Linux system operting on the device.

    Any other questions I'd be glad to answer, or any suggestions on how to make this work, consistantly.

    Maybe my ignorance of Linux is showing and I will gladly trade ignorance for information. If you can find a problem with or give me a procedure for doing this that I can follow. I will be forever indebit to you!

    I am running Debian Wheezy on an i5-3450 Intel w/32 GB memory.

    Thanks for even reading through all of this.


    Jack

  2. #2
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    209
    Found the problem...

    What they did was to create a directory in /dev/mp
    and then mount to it with mount -t vfat /dev/tmp /media/boot

    That's all there is to it... After a number of months! ughh....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •