Find the answer to your Linux question:
Results 1 to 9 of 9
Hi this is my first post, and I'm stuck on trying to install a wifi driver for my Linux system mint 10. The wifi adapter is a ralink 150 Mbit/s ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2013
    Posts
    6

    Help needed with wifi driver installation failure


    Hi this is my first post, and I'm stuck on trying to install a wifi driver for my Linux system mint 10. The wifi adapter is a ralink 150 Mbit/s which comes with instructions on how to install the driver but I get an error when i try to do the ./clean step after makeing it. It says Error : Module r8192s_usb does not exist in /proc/modules
    Error: Module ieee80211_rsl does not exist in proc/modules
    Error: Module ieee80211_crypt_ccmp does not exist in proc/modules
    Error: Module ieee80211_crypt_tkip does not exist...
    Error: Module ieee80211_crypt_wep does not exist...
    Error: Module ieee80211_crypt does not exist in proc/modules

    The instructions say to run the ./clean command after the make but I get that. I tried skipping it and running the next, insmod 8192cu.ko but it says -1 operation not permitted. Any help will b much appreciated.

  2. #2
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    Hello and welcome.

    I think you'll find the error message, "Module r8192s_usb does not exist in /proc/modules" refers to Realtek, not Ralink.

    Also noticed you're using Mint 10. That distro version was introduced several years ago and the Realtek firmware was included in the kernel (linux-image-2.6.32-21-generic). Since then, Debian most and most Debian-based distros have moved the non-free firmware out of the kernel and into separate packages.

    Not sure how you're installing or which kernel you're using, but you may be able to install 'firmware-realtek' with the package manager.

  3. #3
    Just Joined!
    Join Date
    May 2013
    Posts
    6
    I'm using terminal. But for some reason following the instructions doesn't work.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2013
    Posts
    6
    And ur right the path doesn't exist

  6. #5
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    Some info will help. Can you post the results of...
    Code:
     lspci -v
    and
    Code:
     uname -r
    What's the web address of the instructions you're following?

  7. #6
    Just Joined!
    Join Date
    May 2013
    Posts
    6
    How do I post pictures?

  8. #7
    Just Joined!
    Join Date
    May 2013
    Posts
    6
    I'm using my iPad to get on the net

  9. #8
    Just Joined!
    Join Date
    May 2013
    Posts
    6
    The instructions are on a cd that came with it which has the drivers on it.mi just can't get them installed.

  10. #9
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    This thread discusses the same problem as yours... and how the wifi problem was solved.

    [SOLVED] Driver doesn't work

    Good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •