Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 39
Yesterday I noticed my laptop (a Lenovo G770) running Linux Mint 14 seemed to be running especially slowly, taking a long time to open basic programs. gedit didn't seem to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2013
    Posts
    18

    My laptop's HDD having read problems; need help diagnosing (fsck?)


    Yesterday I noticed my laptop (a Lenovo G770) running Linux Mint 14 seemed to be running especially slowly, taking a long time to open basic programs. gedit didn't seem to want to open at all. The next time I turned it on, it displayed the initial "hit F12 for BIOS" screen and went through GRUB as normal, but then went black with a single, unresponsive command cursor in the top left corner. As far as I can tell, it stays on this screen indefinitely.

    I tried selecting recovery mode in GRUB and from the recovery menu ran fsck. It keeps displaying blocks of code like this, with the underscore on the second line a three or four-digit number that usually increments by four with each new message.

    /dev/sda6: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY. (i.e. without -a or -p options)
    mountall: fsck / [___] terminated with status 4
    mountall: filesystem has errors: /
    mountall: skipping mounting / since Plymouth is not available
    fsck from util-Linux 2.20.1
    fsck: WARNING: bad format on line 15 of /etc/fstab
    Error reading block 14155871 (Attempt to read block from filesystem resulted in short read) while getting next inode from scan.


    Everything else about the message, including the block number, is the same each time. I dual-boot Windows 7 on my laptop, and it boots just fine. I was also able to access my third partition to back up my music and pictures; I even managed to start a root-level command line from the recovery menu and copy some files I wanted to save over to this partition after manually mounting it.

    I am unsure how to proceed or what level of action will be required to fix this problem--can I do something specifically to fix it, do I need to format the partition and reinstall the OS, or is the hard drive kaput? (Even though the other two partitions seem fine) I am unfamiliar with fsck or how I would run it manually to further diagnose this issue, and I don't have much time this week for an extensive hacking session to figure it out. Any advice is greatly appreciated.

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,120
    I.d first backup what I want to keep. Documents, movies,music. Then cross my fingers next. Open terminal and type in

    Code:
    cat /etc/fstab
    post output in next post because you are told

    fsck: WARNING: bad format on line 15 of /etc/fstab
    Me. If I have a corrupted hardrive (I run some flash drive installs) I boot a Parted Magic live session or any Linux live session you prefer with Gparted in it. Then I run check from right click in menu in Gparted on the partition I want to fix.

    http://i.stack.imgur.com/dkU4j.png

    A live session of gparted will make sure you unmount the partition before you do fsck so you do not damage the drive and partition.
    Sometimes these problems happen with a abrupt shutdown due to power failure.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined!
    Join Date
    Aug 2013
    Posts
    18
    So I want to boot some distro of Linux from a flash drive and run Gparted--do I have to install Gparted during the live session or is there a way to do so before? Is there any advantage to using Parted Magic?

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,120
    No advantage to running gparted in parted magic. I just keep a parted magic iso for trouble shooting purposes and its special tools. Like a wrench in a tool box.

    No need to install gparted. Just run it in a live cd session. look up live session on google if ya don't know what I mean.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Just Joined!
    Join Date
    Aug 2013
    Posts
    18
    Apparently there is also a bootable version of GParted, GParted Live. Have you considered that?

  6. #6
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,120
    That will work also. You say potato. I say tomato. Either way. Either one will get the job done.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  7. #7
    Just Joined!
    Join Date
    Aug 2013
    Posts
    18
    Contents of /etc/fstab (I won't give the comments, number of spaces approximated):

    Code:
    #
    #
    #
    #
    #
    #
    #
    proc       /proc       proc     nodev,noexec,nosuid 0       0
    #
    UUID=45ff03d0-5f86-4542-a801-149f9508a7aa /                ext4    errors=remount-ro  0     1
    #
    UUID=26632d70-9032-48cf-aab5-b3dc74664d7c none       swap     sw    0      0
    #
    UUID=F248D7E148D7A2A1 /media/david/F248D7E148D7A2A1    ntfs defaults,nls=utf8,uid=1000,windows_names   0   0
    That last line is my data partition.

    I can't install Gparted when running Linux Mint live, even though I left 100 MB of space to keep things in when I created the bootable flash drive with unetbootin. When I try to run GParted on GParted Live, I get an error popup saying "Assertion (head size <= 63) at ../../../libparted/labels/dos.c:662 in function probe_partition_for_geom failed." What do you suggest I do? How would I have space to install it on a Linux live session?

  8. #8
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,120
    Linux Mint Forums ? View topic - [SOLVED] Problem with installation Mint 10 64bit from USB

    I am guessing your malformed line 15 is the Windows NTFS partition

    Code:
    sudo blkid
    will give the UUID number to make sure it matches what you posted

    UUID=F248D7E148D7A2A1
    For the rest. I guess you can look at the below thread

    Linux Mint Forums ? View topic - What Options are Needed for Mounting Drives?

    I thought you were going to run gparted live instead of Mint live on usb. Or am I misunderstanding you?
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  9. #9
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    If you are using a Mint Live CD, you should have gparted on it. Just open a terminal and type: sudo gparted, then hit the Enter key.

  10. #10
    Just Joined!
    Join Date
    Aug 2013
    Posts
    18
    I ran gparted on Mint Live (the one on GParted Live has that bug); it doesn't seem to make any difference to the boot problem. I get this output:


    calibrate /dev/sda6 00:00:00 ( SUCCESS )

    path: /dev/sda6
    start: 1,097,826,304
    end: 1,465,147,391
    size: 367,321,088 (175.15 GiB)
    check file system on /dev/sda6 for errors and (if possible) fix them 00:00:22 ( SUCCESS )

    e2fsck -f -y -v /dev/sda6

    Pass 1: Checking inodes, blocks, and sizes
    Error reading block 14680492 (Attempt to read block from filesystem resulted in short read) while getting next inode from scan. Ignore error? yes

    Force rewrite? yes

    Pass 2: Checking directory structure
    Pass 3: Checking directory connectivity
    Pass 4: Checking reference counts
    Pass 5: Checking group summary information

    235365 inodes used (2.05%, out of 11485184)
    2893 non-contiguous files (1.2%)
    176 non-contiguous directories (0.1%)
    # of inodes with ind/dind/tind blocks: 0/0/0
    Extent depth histogram: 197998/98/1
    2861005 blocks used (6.23%, out of 45915136)
    0 bad blocks
    1 large file

    169309 regular files
    27111 directories
    57 character device files
    25 block device files
    0 fifos
    15 links
    38846 symbolic links (37170 fast symbolic links)
    8 sockets
    ------------
    235371 files
    e2fsck 1.42.5 (29-Jul-2012)
    grow file system to fill the partition 00:00:00 ( SUCCESS )

    resize2fs /dev/sda6

    resize2fs 1.42.5 (29-Jul-2012)
    The filesystem is already 45915136 blocks long. Nothing to do!



    Also, line 15 of /etc/fstab appears to be the blank line after the ntfs partition. The UUIDs do apear to match. That fstab file has been successfully mounting that partition for a while now.

    After than I tried running fsck from the Linux Mint recovery menu, but it prints a few messages about superblock last write times and what appears to be a status message for /dev/sda6 (the partititon I just checked), then doesn't print anything else. I can't tell if it's still working.
    Last edited by dpitch40; 08-28-2013 at 04:06 AM.

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •