Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I have sane installed on my Debian Linux box and it finds the scanner with sane-find-scanner, but when I use the scanimage -L option it states it cannot find ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    279

    Anyone know sane?


    Hi, I have sane installed on my Debian Linux box and it finds the scanner with sane-find-scanner, but when I use the scanimage -L option it states it cannot find the scanner. All of the information I can find assumes that when sane-find-scanner finds the scanner everything is fine, yet it doesn't work that way, as usual. I had this installed previously under a 32 bit earlier version of Debian and it worked ok via the network, now nothing seems to work at all. I've followed the information on that setup sites and they all have the same basic information about setting the defaults and Ethernet addresses, so I'm stuck about what to do next. Any suggestions? I noticed the only other query was from 2011 with no answer...

    Thanks

    Jack

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    When you run scanimage -L, do you get the standard paragraph "No scanners were identified. If you..."?
    What exactly happens when you try to scan? What happens when your run it from the terminal? /usr/bin/xsane?

  3. #3
    Linux User jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    279
    Here is the output from the utilities...

    Code:
    root@Jacks-Debian-7:/home/jack# sane-find-scanner
    
      # sane-find-scanner will now attempt to detect your scanner. If the
      # result is different from what you expected, first make sure your
      # scanner is powered up and properly connected to your computer.
    
      # No SCSI scanners found. If you expected something different, make sure that
      # you have loaded a kernel SCSI driver for your SCSI adapter.
    
    found USB scanner (vendor=0x9e88 [FTDI], product=0x9e8f [SheevaPlug JTAGKey FT2232D B]) at libusb:003:002
    found USB scanner (vendor=0x04b8 [EPSON], product=0x0853 [USB2.0 MFP(Hi-Speed)]) at libusb:002:007
      # Your USB scanner was (probably) detected. It may or may not be supported by
      # SANE. Try scanimage -L and read the backend's manpage.
    
      # Not checking for parallel port scanners.
    
      # Most Scanners connected to the parallel port or other proprietary ports
      # can't be detected by this program.
    root@Jacks-Debian-7:/home/jack#
    The Epson entry is the actual multifunction printer/scanner, it's an Artisan 810. Although not actually supported, I've used it before and it does work with sane...
    Here is the output from scanimage -L..

    Code:
    root@Jacks-Debian-7:/home/jack# scanimage -L
    
    No scanners were identified. If you were expecting something different,
    check that the scanner is plugged in, turned on and detected by the
    sane-find-scanner tool (if appropriate). Please read the documentation
    which came with this software (README, FAQ, manpages).
    root@Jacks-Debian-7:/home/jack#
    I don't usually run them as root, but it doesn't seem to make a difference...

    When I run xsane, I get "no scanners found" window. The help is everything I've tried, along with running it in root, which Sane complains and says not to...

    Thanks for the help...

    Jack

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    279
    Everyone that has assisted... I just wanted to let them know that the image (executable) appears to have been the problem... As I removed then reinstalled the package and it fixed the problem. Although I have not tested it via the Ethernet connection the USB seems to work properly now. Without the 'segmentation fault' error that was randomly showing it's ugly head...

    Right arm for SANE....

    Thanks to all..

    Jack

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •