Find the answer to your Linux question:
Results 1 to 7 of 7
I tried to install bumblebee from source following these instructions but failed to build the binaries github.com/Bumblebee-Project/Bumblebee/wiki/Install-and-usage This is what I did... # ./configure CONF_DRIVER=nvidia CONF_DRIVER_MODULE_NVIDIA=nvidia CONF_LDPATH_NVIDIA=/usr/lib64:/usr/lib CONF_MODPATH_NVIDIA=/usr/lib64/xorg/modules checking for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2013
    Posts
    22

    NVIDIA + Bumblebee: Failed to build the binaries


    I tried to install bumblebee from source following these instructions but failed to build the binaries
    github.com/Bumblebee-Project/Bumblebee/wiki/Install-and-usage

    This is what I did...

    # ./configure CONF_DRIVER=nvidia CONF_DRIVER_MODULE_NVIDIA=nvidia CONF_LDPATH_NVIDIA=/usr/lib64:/usr/lib CONF_MODPATH_NVIDIA=/usr/lib64/xorg/modules
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking how to create a pax tar archive... gnutar
    checking for gcc... gcc
    checking whether the C compiler works... yes
    checking for C compiler default output file name... a.out
    checking for suffix of executables...
    checking whether we are cross compiling... no
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking whether gcc and cc understand -c and -o together... yes
    checking for help2man... no
    configure: WARNING: cannot find help2man, you will not be able to generate manpages
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for x11... yes
    checking for glib... yes
    checking for libbsd... yes
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: executing depfiles commands

    # make
    depbase=`echo src/bbsocket.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`;\
    gcc -DPACKAGE_NAME=\"bumblebee\" -DPACKAGE_TARNAME=\"bumblebee\" -DPACKAGE_VERSION=\"3.2.1\" -DPACKAGE_STRING=\"bumblebee\ 3.2.1\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DCONF_XDISP=\":8\" -DCONF_SOCKPATH=\"/var/run/bumblebee.socket\" -DCONF_GID=\"bumblebee\" -DCONF_KEEPONEXIT=\"false\" -DCONF_FALLBACKSTART=\"false\" -DCONF_VGLCOMPRESS=\"proxy\" -DCONF_TURNOFFATEXIT=\"false\" -DCONF_BRIDGE=\"auto\" -DCONF_PRIMUS_LD_PATH=\"/usr/lib/primus:/usr/lib32/primus\" -DCONF_PIDFILE=\"/var/run/bumblebeed.pid\" -DCONF_PM_METHOD=\"auto\" -DCONF_DRIVER=\"nvidia\" -DCONF_DRIVER_MODULE_NVIDIA=\"nvidia\" -DCONF_LDPATH_NVIDIA=\"/usr/lib64:/usr/lib\" -DCONF_MODPATH_NVIDIA=\"/usr/lib64/xorg/modules\" -DDAEMON_NAME=\"bumblebeed\" -DPACKAGE=\"bumblebee\" -DVERSION=\"3.2.1\" -DWITH_PIDFILE=1 -I. -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DCONFIG_FILE='"/usr/local/etc/bumblebee/bumblebee.conf"' -DCONF_XORG='"/usr/local/etc/bumblebee/xorg.conf.DRIVER"' -DCONF_XORG_DIR='"/usr/local/etc/bumblebee/xorg.conf.d"' -Wall -Waggregate-return -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes -Winline -Wformat=2 -pipe -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -Wextra -funsigned-char -DGITVERSION='"3.2.1"' -g -O2 -MT src/bbsocket.o -MD -MP -MF $depbase.Tpo -c -o src/bbsocket.o src/bbsocket.c &&\
    mv -f $depbase.Tpo $depbase.Po
    src/bbsocket.c: In function ‘socketConnect’:
    src/bbsocket.c:51: error: ‘SOCK_CLOEXEC’ undeclared (first use in this function)
    src/bbsocket.c:51: error: (Each undeclared identifier is reported only once
    src/bbsocket.c:51: error: for each function it appears in.)
    src/bbsocket.c: In function ‘socketServer’:
    src/bbsocket.c:175: error: ‘SOCK_CLOEXEC’ undeclared (first use in this function)
    make: *** [src/bbsocket.o] Error 1

    some additional info...
    Distro: CentOS 5.9
    Kernel: 2.6.18-348.el5 x86_64
    Manufacturer and model: ThinkPad Edge E330 3354CTO
    Bumblebee version: bumblebee-3.2.1
    Graphic Cards:
    # lspci -vnn | grep '\''[030[02]\]'
    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1058] (rev a1) (prog-if 00 [VGA controller])

    Please help to resolve the error. Thanks.

  2. #2
    Just Joined! Andy_Crowd's Avatar
    Join Date
    Sep 2013
    Location
    日不落
    Posts
    62

  3. #3
    Just Joined!
    Join Date
    May 2013
    Posts
    22
    I have installed the following Build Requirements

    pkg-config (already installed)
    glib-2.0 and development headers (already installed)
    libx11 and development headers (already installed)
    libbsd and development headers (installed libbsd-0.6.0-1.el5.x86_64.rpm and libbsd-devel-0.6.0-1.el5.x86_64.rpm)
    help2man (haven't installed)

    since I downloaded source tarball from
    bumblebee-project.org/install.html
    and not building from git, I suppose do not need autotools (2.68+)

    Other than that I don't think I need Runtime Dependencies for building?

  4. #4
    Just Joined!
    Join Date
    May 2013
    Posts
    22
    I have double checked the build requirements and all required packages are installed except help2man and autotools2.68.
    Is this error because of too old kernel?

  5. #5
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,048
    Old kernel maybe but certainly out of date gcc and glibc could do it.

  6. #6
    Just Joined!
    Join Date
    May 2013
    Posts
    22
    I have these versions

    glibc-2.5-107.x86_64
    glibc-common-2.5-107.x86_64
    glibc-devel-2.5-107.x86_64
    glibc-headers-2.5-107.x86_64

    gcc-4.1.2-54.el5.x86_64
    gcc-c++-4.1.2-54.el5.x86_64
    libgcc-4.1.2-54.el5.x86_64

    could that be a problem?

  7. #7
    Linux Engineer
    Join Date
    Dec 2013
    Posts
    1,048
    Could be - they're quite outdated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •