Find the answer to your Linux question:
Results 1 to 7 of 7
I am running Linux Mint 16 Cinammon on my Dell Inspiron 580s Desktop PC . Recently, I obviously made a big mistake by downloading both Linux Bodhi 64-bit version and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2014
    Posts
    3

    Unable To Open 32GB USB Drive; Don't Understand Error Messages


    I am running Linux Mint 16 Cinammon on my Dell Inspiron 580s Desktop PC. Recently, I obviously made a big mistake by downloading both Linux Bodhi 64-bit version and Puppy Linux on to the same drive. What I mean is that when I had to tried to open and view critical files I had backed up on it on Windows PCs, I had been getting more and more error messages about drive formatting errors. Even worse, it was showing the flash drive as having NO folders/files on it, and then showing all the files I had saved to it when I still went ahead and double-clicked to open it!?

    Tonight I tried again to open the USB drive in Linux Mint 16, only to see the exact following lines in an error message window:

    Unable to mount Bodhi Linux

    "Error mounting /dev/sdf2 at /media/craig/Bodhi Linux: Command-line `mount -t "iso9660" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,io charset=utf8,mode=0400,dmode=0500" "/dev/sdf2" "/media/craig/Bodhi Linux"' exited with non-zero exit status 32: mount: block device /dev/sdf2 is write-protected, mounting read-only
    mount: wrong fs type, bad option, bad superblock on /dev/sdf2,
    missing codepage or helper program, or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so"

    I am a complete newbie, so I can't quite decode all of this message, and have already tried getting any answer from the Linux Mint forum.

    When I enter "mount -t "iso9660" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,io charset=utf8,mode=0400,dmode=0500" into a Terminal window, all I get is > on the next line. What?? What am I supposed to enter as a command or commads? Even entering "dmesg | tail or so" totally lost me with this puzzling response:

    tail: cannot open ‘or’ for reading: No such file or directory

    At this point, all I want to do is be able to save the non-Linux critical folders and files to my SATA hdd and then reformat the drive to what file extension? If I must just go ahead and reformat the drive and lose everything on it, so be it. Another very costly and painful lesson hopefully learned. Actually, I can't even get Mint 16 to give me any way to even reformat the drive! Good grief. I hate Windows, but feel forced to prefer the dumbness or simplicity of its click, click, click, or double-click and the task is done!

  2. #2
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,281
    iso9660 is the filesystem type for cdroms. I doubt if a pendrive would be formatted that way; in fact if you have Windows files on it, it's probably formatted with ntfs. The distro installation images you downloaded will be stored as individual files on this drive. That "wrong fs type or bad superblock" message usually means that you (or in this case your system) have tried to mount a drive with the wrong format type.

    Trying dmesg was a good idea, but I wouldn't use tail in this case because what you are interested is the line that shows how your kernel thinks this drive is formatted, and that won't necessarily be near the end. Try dmesg|grep sdf2. Grep shows the line(s) that contains a particular string and that should show the actual filesystem on the sdf2 drive. Then we can go on from there.

    One important lesson you can learn is that in Linux, when you get into a hole, you can usually dig your way out again if you work systematically and don't panic.
    Oh, btw, don't include odd words like "or so" in commands; that's what got you the error message in tail.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  3. #3
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I obviously made a big mistake by downloading both Linux Bodhi 64-bit version and Puppy Linux on to the same drive.
    You probably need to clarify what you did because simply downloading to iso files (Bodhi and Puppy) to the same drive or even the same partition or the same directory is not going to pose a problem. You should be able to loop mount either or both to look at files.

    So what was on the 'flash' you refer to? Is that where you downloaded Bodhi and Puppy and also had windows files? Is this the sdf drive?
    Posting the output of the command suggested by hazel should be a good starting point.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer docbop's Avatar
    Join Date
    Nov 2009
    Location
    Woodshed, CA
    Posts
    949
    Here's Puppy's instructions for installing on a USB drive. May want to start there, running on USB was kind of Puppy's first focus.

    Puppy on USB pen drive

  6. #5
    Just Joined!
    Join Date
    Feb 2014
    Posts
    3
    Dear hazel,

    First of all, thank you for your response! I entered the exact string you said to in a Terminal window and here are the results:

    [134649.518453] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    [134649.859328] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    [134683.210106] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    [200567.296112] sdf: sdf1 sdf2 < sdf5 >
    [200568.530077] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    [200568.635163] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    3.210106] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32


    In all three lines, the sdf2/5 characters were highlighted in red. All I can understand is that I am still deadlocked and lost. I had the usb drive plugged into a port when I entered the command. Hopefully, you can make some sense of it all.

  7. #6
    Just Joined!
    Join Date
    Feb 2014
    Posts
    3
    Thank you for replying. I looked at my original post and don't see where I said "flash," so I'm not sure how to answer your question. What I did say was: "...made a big mistake by downloading both Linux Bodhi 64-bit version and Puppy Linux on to the same drive." The drive I was referring to was the 32GB Flash or USB Drive I can't even open. I did try the piped command that hazel suggested, with no success. As I told her, this was the result in the terminal window with the USB drive plugged in:

    [134649.518453] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    [134649.859328] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    [134683.210106] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    [200567.296112] sdf: sdf1 sdf2 < sdf5 >
    [200568.530077] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    [200568.635163] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    [201596.048387] sdf: sdf1 sdf2 < sdf5 >
    [201597.321714] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32
    [201597.392937] isofs_fill_super: bread failed, dev=sdf2, iso_blknum=16, block=32


    My flash drive does have Windows files on it, but I am not sure if it is formatted right. Probably not, from the looks of it.

  8. #7
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    mount: block device /dev/sdf2 is write-protected, mounting read-only
    That's not a problem or an error just information. If you are trying to mount an iso filesystem that is expected behavior as they are read-only fielesystems.

    /media/craig/Bodhi Linux
    I'm still not sure about your setup. As I understand it, you have a 32GB usb drive and you have iso files of Puppy Linux and Bodhi Linux downloaded on it and you also have some windows files on it, is that correct? If you had windows files on it prior to downloading Puppy and Bodhi, the filesystem type is most likely ntfs or vfat. The command: df -T will show the filesystem type but only on mounted partitions and we don't know if this partition is mounted. Try running the command from Mint. If that doesn't work or show the drive or its partitions, use the command below. If you get a message indicating parted is not installed, you can install it with: sudo apt-get install parted. Parted will show both mounted and unmounted partitions.

    parted /dev/sda print all

    If you were trying to mount the iso at the mount point above in a terminal, you would need to put double quotes around the above part as you have a space in the name. Don't think that is the problem however.

    mount: wrong fs type, bad option, bad superblock on /dev/sdf2,
    Could you post the exact command you entered to get the above message?

    When I enter "mount -t "iso9660" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=100 0,io charset=utf8,mode=0400,dmode=0500" into a Terminal window, all I get is > on the next line
    I would expect that as you have not listed a device to mount or a mount point in the command so it is waiting for you to finish. If you have an iso file named bodhi.iso and you want to mount it in the /media/craig/Bodhi Linux directory you could do this:

    Code:
    mount -o loop bodhi.iso "/media/craig/Bodhi Linux"
    If you are in a terminal, case sensitivity applies and spaces are problematic and require an escape character or quotes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •