Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Synaptics Touchpad issues


    Hello everyone,

    I'm hoping for some guidance on this issue I'm having with my laptops synaptics touchpad. The touch pad is completely un-responsive and it does not detect any movement or clicks. It is almost as though the touchpad does not exist. I'm fairly sure the drivers are installed though as the GUI displays the touch pad and has it set to "on". Screenshot of the GUI is below.

    Touchpad_gui_on.jpg

    I have tried to create the /etc/X11/xorg.conf.d/synaptics.conf file as some online guides mention but have had no luck in getting the touchpad working.

    Further information which may be useful, USB mouse works fine as does the touchscreen. I am running Debian (Jessie) & Gnome 3.14.1 and system is up-to-date.

    I'm new to the forum and also new to linux so all help and advice is appreciated, I'd love to get this working so I can continue on my linux learning adventure

    Thanks
    Last edited by Stephen4691; 03-16-2015 at 07:08 PM.

  2. #2

  3. #3
    Hi gregm

    Thanks for the reply! Yes that is the guide I worked from

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Dec 2013
    Location
    Victoria, B.C. Canada
    Posts
    2,103
    The picture you uploaded didn't come through - there seems tobe a forum problem there - so excuse me if this seems redundant. You went to system settings and selected mousepad and touchpad? You see your synaptics touchpad in the dropdown selector as listed by the command "egrep -i 'synap|alps|etps' /proc/bus/input/devices"? It is enabled?

  6. #5
    Strange that the picture doesn't show up, it appeared fine when previewed before posting. To answer your question in the Mouse and Touchpad options the switch is toggled to "On", there is no drop down menu however. Using the command you posted I get the following output: Name="SynPS/2 Synaptics TouchPad".

    So my reasoning is that the device is 100% synaptics. It has to be enabled surely as the GUI has the option to toggle the touchpad on or off.

    Thanks again for the assistance

  7. #6
    Linux Guru
    Join Date
    Dec 2013
    Location
    Victoria, B.C. Canada
    Posts
    2,103
    I have two possible options in mine. One is the "SynPS/2 Synaptics TouchPad". My gui widget is likely different from yours since I'm running Xfce.

    Your desktop settings can override the system settings (the conf file you created). Does your desktop mousepad widget have settings for mouse speed etc? Did you open the touchpad tab?

  8. #7
    OK I'll talk you through the desktop GUI to try and give you an idea of what I have in front of me.

    1) Settings
    2) Mouse & Touchpad

    Then I have the following options:

    General
    Primary Button (x)Left ( )Right
    Double-click Slow ---------------x------- Fast

    Touchpad ON
    Pointer Speed Slow --------x------------ Fast
    ( ) Disable While Typing ( ) Two Finger Scroll
    ( ) Tap to click ( ) Natural Scrolling

    I have tried toggling various option in different combinations to no avail. I have toggle the touchpad on and off several times as well as rebooted after changing conf. I have went back to using the default conf now in case I made any errors and still having no luck

  9. #8
    Linux Guru
    Join Date
    Dec 2013
    Location
    Victoria, B.C. Canada
    Posts
    2,103
    You should have an app called synclient on your machine - it installs with the synaptics drivers.
    Code:
    synclient -l
    will list the current settings for the driver. TouchpadOff should be equal to 0.
    You can test various settings this way:
    Code:
    synclient TouchpadOff=0
    That would turn the touch pad on if it were off.

  10. #9
    synclient TouchpadOff=0

    I have changed it to 1 and back to 0 in an attempt to get it running but still no luck. Scouring the web looking for solutions but none seem to work

  11. #10
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    13,381
    After setting it to 0, did you try rebooting the system? Also, if this requires proprietary (non-FOSS) drivers, then Debian will not install them by default. You may need to download and install them yourself. Just because the system recognizes the device and type, doesn't mean it can control it without those drivers (kernel modules and possibly firmware).
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •