Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
I'm not sure if this is a hardware problem, but ever since I switched to Linux, my computer won't play DVDs. With CDs, everything's fine, but aas soon as I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    68

    DVD Troubles


    I'm not sure if this is a hardware problem, but ever since I switched to Linux, my computer won't play DVDs. With CDs, everything's fine, but aas soon as I slip a DVD in the drive, it starts acting up. It won't automount, and when I do it manually, it just won't read the disk. I'm running Fedora Core 1. Any suggestions?

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Well are they like movies on DVD or data dvds or what?

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    68
    They're DVD movies.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Have you tried playing them with something like ogle or mplayer?

  6. #5
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Also, make sure you have libdvdcss installed.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  7. #6
    Just Joined!
    Join Date
    Dec 2004
    Posts
    68
    I've tried mplayer, and I installed libdvdcss. Nothin' doin'.

  8. #7
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    You said you tryed the automount, have you try manual mount?
    what application are you using? (other then mplayer)
    does it give you an error message?
    Can you read DVD with only data on it. (data dvd - no dvd movies)?
    Is mplayer playing regular movie (divx, mov, mpg, mp3)?


    You been very evasive on the answer, you have to know we do not know your configuration, giving us as much information as possible is a must if you need proper help.
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  9. #8
    Just Joined!
    Join Date
    Dec 2004
    Posts
    68
    Alright, let's see here:

    I have tried manually mounting it. It does, but the DVD won't automatically play.
    When I pull up mplayer and try to get it to play, it tells me:

    "FATAL: Could not initialize video filters (-vf) or video output (-vo)."

    I've also tried gxine, which tells me:

    "xine engine failed to start.

    No input plugin found.
    Maybe the file does not exist, has wrong permissions or
    url syntax error"

    Another box also pops up, saying:

    "Read error from: /dev/dvd"

    I don't have any data DVDs to try out.

    I don't have any mpeg files on my computer. Where can I get some?

  10. #9
    Just Joined!
    Join Date
    Dec 2004
    Posts
    68
    I tried some sites, and most streaming videos work fine with gxine.

  11. #10
    Just Joined!
    Join Date
    Dec 2004
    Posts
    68
    I decided to try something other than mplayer and gxine, so I installed ogle and the ogle GUI. I put my disc in, typed "ogle" in the Terminal. The ogle GUI popped up, and the disc spun a little. Nothing happened. Then I went to 'File' on the GUI, chose 'Open disc' from the drop down menu, and received this error message in the Terminal:

    "libdvdread: Can't stat /dev/dvd
    No such file or directory
    ERROR[ogle_nav]: faild to open/read the DVD
    callbacks.on_opendvd_activate(): DVDSetDVDRoot: Root not set"

    Any ideas what to do?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •