Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I've spent the better part of today in vain trying to get my mouse configured. It's a Logitech USB optical scroll mouse. The weird thing is, just yesterday it was ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630

    Logitech USB optical mouse is driving me over the edge...


    I've spent the better part of today in vain trying to get my mouse configured. It's a Logitech USB optical scroll mouse.

    The weird thing is, just yesterday it was working perfectly! To retrace, I installed Slackware 10 Sunday and quickly had my mouse configured and working perfectly. Before I edited the xorg.conf file, the pertinent section looked like this:

    Code:
     
     ********************************************************************** 
    # Core Pointer's InputDevice section 
    # ********************************************************************** 
     
    Section "InputDevice" 
     
    # Identifier and driver 
     
        Identifier  "Mouse1" 
        Driver      "mouse" 
     
    # On platforms where PnP mouse detection is supported the following 
    # protocol setting can be used when using a newer PnP mouse: 
     
    #    Option     "Protocol"      "Auto" 
     
    # The available mouse protocols types that you can set below are: 
    #    Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2 
    #    Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2 
    #    MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse 
    #    ThinkingMouse ThinkingMousePS/2 Xqueue 
        Option "Protocol"    "PS/2" 
     
    # The mouse device.  The device is normally set to /dev/mouse, 
    # which is usually a symbolic link to the real device. 
     
        Option "Device"      "/dev/mouse" 
    #   Option "Device"      "/dev/psaux" 
    #   Option "Device"      "/dev/ttyS0" 
    #   Option "Device"      "/dev/ttyS1" 
     
    # When using XQUEUE, comment out the above two lines, and uncomment 
    # the following line. 
     
    #    Option "Protocol"  "Xqueue" 
     
    # Baudrate and SampleRate are only for some Logitech mice. In 
    # almost every case these lines should be omitted. 
     
    #    Option "BaudRate"          "9600" 
    #    Option "SampleRate"        "150"
    This gave me jerky mouse movement and no scroll. I edited xorg.conf thusly:

    Code:
     
    ********************************************************************** 
    # Core Pointer's InputDevice section 
    # ********************************************************************** 
     
    Section "InputDevice" 
     
    Identifier "Mouse1" 
    Driver "mouse" 
    Option "Buttons" "5" 
    Option "ZAxisMapping" "4 5" 
    Option "Protocol" "IMPS/2" 
    Option "Device" "/dev/mouse" 
     
    # Identifier and driver 
     
    #   Identifier  "Mouse1" 
    #   Driver      "mouse" 
     
    # On platforms where PnP mouse detection is supported the following 
    # protocol setting can be used when using a newer PnP mouse: 
     
    #    Option     "Protocol"      "Auto" 
     
    # The available mouse protocols types that you can set below are: 
    #    Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2 
    #    Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2 
    #    MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse 
    #    ThinkingMouse ThinkingMousePS/2 Xqueue 
    #   Option "Protocol"    "PS/2" 
     
    # The mouse device.  The device is normally set to /dev/mouse, 
    # which is usually a symbolic link to the real device. 
     
    #   Option "Device"      "/dev/mouse" 
    #   Option "Device"      "/dev/psaux" 
    #   Option "Device"      "/dev/ttyS0" 
    #   Option "Device"      "/dev/ttyS1" 
     
    # When using XQUEUE, comment out the above two lines, and uncomment 
    # the following line. 
     
    #    Option "Protocol"  "Xqueue" 
     
    # Baudrate and SampleRate are only for some Logitech mice. In 
    # almost every case these lines should be omitted. 
     
    #    Option "BaudRate"          "9600" 
    #    Option "SampleRate"        "150"
    ..and the mouse worked perfectly with scroll and smoothly. I then decided to try Emerde, a package manager for Slack that, in theory, allows you to install packages from Gentoo Portage. As it turned out, Emerde quickly ate up the small / partition I'd created, so I then decided to do a re-install on larger partitions. All went successfully. Then when I edited my xorg.conf file in exactly the same manner as above, the mouse is all over the place and won't scroll! If i run the courser diagonally up the screen from left to right, the courser disappears about three quarters across and re-appears in the bottom left. Right click doesn't work at all.

    I just don't understand it. The first time I edited xorg.conf, the mouse worked perfectly. The second time, all hell breaks loose and I can't get it configured even having checked and re-checked and re-checked that I'd done everything just right!

    What could be wrong? What am I missing here?? Could it be the module for the mouse is not getting loaded, and it's defaulting to a module that's giving me the problem? ANY thoughts or suggestions will be much appreciated! Thanks.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  2. #2
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    well something to try for now just to see if it works would be to comment the
    Code:
    Option "Protocol" "IMPS/2"
    and just try the
    Code:
    Option     "Protocol"      "Auto"
    this may work till you find the correct setting. which i beleive is
    Code:
     Option "Protocol"    "PS/2"
    Did your by chance messs with other settings within the xorg.conf?

    also you may want to try
    Code:
    Option  "Device" "/dev/input/mice"
    instead of
    Code:
    Option "Device"      "/dev/mouse"
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  3. #3
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    That's why I refuse to use third party packagemanagers, it just does not work in all cases. But okay.

    I have a simular mouse and Slackware 10.0 . Your configuration looks fine to me, it should work that way.

    Do you have gpm active before starting X ? Try to kill that before starting X if so.
    I\'m so tired .....
    #200472

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Thanks for responding. This is getting very frustrating. I looked in /etc/rc.d for rc.gpm and it isn't there although the Slackware site says that's where it is! I decided to uninstall gpm altogether and that made no difference! Right now I'm using:

    Code:
    Section "InputDevice"
     
    Identifier "Mouse1"
    Driver "mouse"
    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"
    Option "Protocol" "Auto"
    Option "Device" "/dev/mouse"
    And it gives me the same thing as when I use "Protocol "PS/2"...Jerky courser and no scroll.

    I'm not understanding what could have been different between the two installs. I did everything exactly the same way. Last time, this wasn't a blip on the screen, and now it is a monumental aggravation!

    Any other ideas? I'm grasping at straws...

    EDIT: I should also add that I run ProMepis and SuSE Pro 9.1 on this same box, and the mouse works perfectly with them. In my Googleing, I ran across a post of a guy in a similar circumstance, and it was suggested that his kernel may be hosed in some way. Is that possible?

    If so, would recompiling or upgrading fix it?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #5
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    Does your /dev/mouse points to the right device file ? Standard it is setup as a symlink to /dev/psaux which is not correct when using an USB mouse. That should be something like /dev/input/mice or /dev/input/mouse0 . (This was mentioned before)
    Code:
    Section "InputDevice"
            Identifier  "Mouse1"
            Driver      "mouse"
            Option      "Protocol" "IMPS/2"
            Option      "Device" "/dev/mouse"
            Option      "Buttons" "5"
            Option      "ZAxisMapping" "4 5"
            Option      "Resolution"   "800"
    EndSection
    Also check the modules loaded for your mouse. You also can try to re´nstall the stock kernel + modules and try again.
    I\'m so tired .....
    #200472

  7. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I edited .xorg.conf to:

    /dev/mouse
    /dev/input/mice
    /dev/input/mouse
    /dev/input/mouse1
    /dev/input/mouse0
    /dev/psaux

    And none would work except /dev/mouse and /dev/psaux which is where /dev/mouse is symlinked. Both give jittery courser and no scroll.

    I even symlinked all of the above to point to /dev/mouse and that didn't work either. So now I'm back with /dev/mouse pointing to /dev/psaux.

    When I went from Core 1 to Core 2 and the 2.6 kernel, the mouse device went from /dev/psaux to /dev/mouse. Is there a module tha loads to tell it to link /dev/mouse to some other device if using USB? Other than the mouse module I deleted, what other mouse modules should I be looking for? Maybe that's not getting loaded for some reason? This one has really got me stumped...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  8. #7
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    This mouse came with one of those little PS/2 adapters. I found it and conneted it to the PS/2 port running:

    Code:
    Identifier "Mouse1"
    Driver "mouse"
    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/mouse"
    And it is working smoothely again with scroll. Why do you think the same hardware would work perfectly as a PS/2 device but won't as a USB device??
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #8
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    I can't check it, because I use 2.6.10-ac10 . But if I recall correctly it should be something like (apart from the usb host modules) :
    Code:
    hid
    mousedev
    evdev
    I\'m so tired .....
    #200472

  10. #9
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Hmmm interesting. Earlier I modprobed hid and mousedev but haven't evdev. I'll try that and see what happens, thanks.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  11. #10
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I give up.

    I loaded all three and symlinked to all the above just as before and nothing worked. I've spent two days on this and am no closer than before. I'll just use the PS/2 adapter and be done with it. puntmuts and loft306 I sure appreciate y'all lending me a hand with this. Thanks.
    Linux Mint + IceWM Registered: #371367 New Members: click here

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •