Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, I'm trying to install a dual boot with Windows XP and Mandrake 10.1 on my system. I currently have a pair of WD 80gb SATA drives set up as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    11

    SiI 3112 SATA RAID0 - Grub/Lilo freezes


    Hi, I'm trying to install a dual boot with Windows XP and Mandrake 10.1 on my system. I currently have a pair of WD 80gb SATA drives set up as a RAID 0 set, using a SiI 3112 controller, and I am having difficulty getting linux to install to or boot from my RAID. I have had no luck with Fedora core 3, and I am now attempting with Mandrake 10.1.

    It seems that I'm getting closer to the solution when using Mandrake. For one, the SiI 3112 controller is listed on the mandrakelinux website as a compatible RAID controller.

    During the install, my HD is not reported as a RAID, but as two separate drives. No real surprise there I guess. Strangely though, it reports all of my partitions as being on sda, leaving sdb empty - but it reports the size of the partitions correctly. This makes the sda3 partition (~130gb fat32) report as being larger than sda as a whole.

    I am able to mount the sda2 partition (20gb ext3) on root, and the installation proceeds flawlessly from this point. When I reboot, however, GRUB or LILO both freeze. GRUB freezes after displaying "GRUB", but LILO returns an L, followed by pairs of 9's for several rows, then freezes. Both the LILO graphical and text bootloaders do the same thing.

    I've also tried using a redhat driver with fedora and a "linux dd noprobe=hde noprobe hdg" command - I learned afterward that apparently redhat and fedora have different driver disk setups, so no wonder it didn't work.

    Other attempts have involved a program I found called Ranish, and another called qtparted? to take care of my partitioning. Both programs recognize and will partition my RAID, but neither seems to help. Knoppix also recognizes my RAID, but I'd like to boot from my harddrive.

    Has anyone managed to install any linux distro on a RAID 0 set with the SiI 3112 SATA controller or have any insight to point me down the right path?

    Thanks

  2. #2
    Just Joined!
    Join Date
    Jan 2005
    Posts
    11
    My Redhat 9 download finally finished - at least the first CD, but that's was enough to determine that it CAN recognize my RAID. I used the same driver disk that I originally tried with FC3, and surprise surprise, redhat supports a redhat driver disk!

    That being said, the past several days spent struggling and googling has somewhat soured my opinion of Linux, but I suppose that my ire should be directed towards the hardware manufacturers for not providing drivers for more distributions.

    I'm sure I'll post again with another crisis soon enough.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •