hey guys

i ve tried to ask for help bout this matter before however i havent found the solution to my problem yet and i ve left it for a while (busy with other things)

i ve got an amilo a1630 laptop with an amd athdlon 64 3700+

i use linux and my distribution is fedora core 3 i386... i ve tried the x86_64 version
however i had some problems with compiling some 32bit applications related to my work
so i left it (i am not an expert in cross-compiling and i could find a workaround so i just returnd to my i386 distro)

well when i had the x86_64 version my /proc/cpuinfo was showing a speed around 2.4 GHz which is the expected one from this processor)
in the i386 version cpuinfo shows a stable 798.194 which does not change whether the machine has a high load or not.
* i dont use cpuspeed*

now what i think about this is:
- either cpuinfo is not so compatible with this cpu and retrieves a false reading
- i dont have an essential kernel module installed related with this cpu and the i386 distro of fc3
- or i dont know something which i have to know!

i would appreciate any help in this matter
i am not sure if this is the correct forum to post my problem, please forgive me in advance if this is the case

thanks
any help will be deeply appreciated
christos